summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorkinokoio2015-08-12 09:48:48 -0500
committerkinokoio2015-08-12 09:48:48 -0500
commitf11fc65f24c9b529a4d61636adce57957222355e (patch)
treeadb3fe09f6b16371ebb761e31b24a9d235809251 /PKGBUILD
downloadaur-sbrowser-git.tar.gz
Initial push
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 21 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..54ad30224bec
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Ivan Pacheco (Kinokoio) <kinokoio@hotmail.com>
+
+pkgname=sbrowser-git
+pkgver=9b861d4
+pkgrel=1
+pkgdesc="Simple browser based on PyQt5 and QtWebKit"
+arch=(any)
+url="https://github.com/kinokoio/sbrowser"
+license=('GPL')
+depends=('python' 'python-pyqt5' 'qt5-base'
+ 'qt5-webkit' 'python-setuptools')
+makedepends=('coreutils' 'git')
+source=("git+https://github.com/kinokoio/sbrowser")
+sha256sums=("SKIP")
+
+package() {
+ cd "$srcdir/sbrowser"
+ python setup.py install --root="$pkgdir/" --optimize=1
+ install -Dm755 LICENSE $pkgdir/usr/share/doc/sbrowser/LICENSE
+ install -Dm755 README.md $pkgdir/usr/share/doc/sbrowser/README
+}