summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRhinoceros2017-02-20 10:00:34 +1100
committerRhinoceros2017-02-20 10:13:32 +1100
commit39e1801d36f9c205aef5221ddf92232fb5d9eeab (patch)
tree751d42c83773bcc4a486c9e86656378e19ed8c7a /PKGBUILD
parentec25900e949786ebbc2dada9e1d02c5721f8f1d8 (diff)
downloadaur-39e1801d36f9c205aef5221ddf92232fb5d9eeab.tar.gz
Upgrade to 0.5.0-1
* Upstream changelog: https://github.com/andmarti1424/sc-im/releases/tag/v0.5.0 * Add depends on libxml2 and libzip from namcap's suggestions * Remove ncurses depends, since it's implied from other depends * Remove backspace patch; it's now working * Add patch to install package in the correct location
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 7 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 04cdf426f14d..98b4eae6b769 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,24 +2,24 @@
# Contributor: Rhinoceros <https://aur.archlinux.org/account/rhinoceros>
pkgname=sc-im
-pkgver=0.4.0
+pkgver=0.5.0
pkgrel=1
pkgdesc='A spreadsheet program based on SC'
arch=('i686' 'x86_64')
url='https://github.com/andmarti1424/sc-im'
-depends=('ncurses')
+depends=(libxml2 libzip)
license=('BSD')
conflicts=('scim-spreadsheet')
source=("https://github.com/andmarti1424/$pkgname/archive/v${pkgver}.tar.gz"
- 'fix_backspace.patch')
-sha256sums=('e9a6d0a87d4f9a657bb8b87bdde9141e42c8916fbb6879d07564ffb67302f68a'
- 'c8e2268f1491c072d5d8c11ae682983f6d30a8b30f5a5a0c4fcc9811c659b329')
+ 'arch.patch')
+sha256sums=('d7a31c5225e02239e925b50b414d7e69d12bc3554f218621823782872ccc5e4d'
+ '76bbe0e1e96e2623b8304f267f7cf310ee2f82e222c57a318d0e3434963203ba')
MAKEFLAGS='-j1'
prepare() {
cd "$pkgname-$pkgver/src"
- # apply patch to make backspace work
- patch <../../../fix_backspace.patch
+ # install things in the correct place for package managers
+ patch <../../../arch.patch
}
build() {