summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRhinoceros2016-05-12 11:57:30 +1000
committerRhinoceros2016-05-12 11:57:30 +1000
commitb5d427ff859a0df4aa76c277ec4ae87f2833b70d (patch)
treea68bb78539fac4d40c7ecb4dee812fba8138647b /PKGBUILD
parentc9745d8ef86cad6949978bc0cd5cde917ad778e8 (diff)
downloadaur-b5d427ff859a0df4aa76c277ec4ae87f2833b70d.tar.gz
Update to 0.3.0
* Added prepare section to make properly * Upstream changelog: * FIX when importing large CSV files * SC-IM now supports wide chars, enabling the use of different alphabets. The following alphabets are supported: English, Spanish, French, Italian, German, Portuguese, Russian, Ukrainian, Greek, Turkish, Czech, Japanese, Chinese * Modification in padding of cells and how they are saved in files. * UNDO / REDO improvements. Now the following actions are supported: Change in format of a column as a result of the 'f' command Change in format of a column as a result of auto_jus Change format of columns as a result of ic dc
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 7 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8804b572a812..61f97f475df9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Rhinoceros <https://aur.archlinux.org/account/rhinoceros>
pkgname=sc-im
-pkgver=0.2.2
+pkgver=0.3.0
pkgrel=1
pkgdesc='A spreadsheet program based on SC'
arch=('i686' 'x86_64')
@@ -10,9 +10,14 @@ url='https://github.com/andmarti1424/sc-im'
license=('BSD')
conflicts=('scim-spreadsheet')
source=("https://github.com/andmarti1424/$pkgname/archive/v${pkgver}.tar.gz")
-sha256sums=('c47ac3c273da804f9fda1c3bdcc5570f471fc26234183a9a1ed70f3e65a20cb7')
+sha256sums=('d721e8fb850ebe3c590311ab14e37e92b3340a19e41cdfd67798fdcfac6fae3b')
MAKEFLAGS='-j1'
+prepare() {
+ cd "$pkgname-$pkgver/src"
+ sed -i 's/#include <ncursesw\/curses.h>/#include <ncurses.h>/' *.c *.h
+}
+
build() {
cd "$pkgname-$pkgver/src"
make