summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFrank Seifferth2020-06-03 21:03:54 +0100
committerFrank Seifferth2020-06-03 21:41:19 +0100
commit124de0f64c68df3b07d89e2455e61b1dc38ee68d (patch)
tree73aaac916a88b4e28f7f3b76c01d8e9ad75910b6 /PKGBUILD
parent03dd45ebc22dcf8e9065848f7b639d8608990f73 (diff)
downloadaur-124de0f64c68df3b07d89e2455e61b1dc38ee68d.tar.gz
Incorporate recent changes from sc-im PKGBUILD
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 7 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 64013370aed7..d571e64f1d5e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,19 +8,23 @@ pkgdesc='A spreadsheet program based on SC'
arch=('i686' 'x86_64' 'armv7h')
url='https://github.com/andmarti1424/sc-im'
depends=(libxml2 libzip)
-optdepends=('libxlsxwriter: export to xlsx')
+optdepends=('libxlsxwriter: export to xlsx. Requires rebuild of sc-im'
+ 'gnuplot: create graphs')
+makedepends=(gcc8)
license=('BSD')
conflicts=('scim-spreadsheet' 'sc-im')
source=('git://github.com/andmarti1424/sc-im'
'arch.patch')
md5sums=('SKIP'
- '9a71ebf916378831bc1600d3581a126b')
+ '51e2712b355accd9771ccbaf24b0ac8a')
MAKEFLAGS='-j1'
prepare() {
cd "$srcdir/sc-im/src"
# install things in the correct place for package managers
patch < "$srcdir/arch.patch"
+ cd ..
+ patch -p1 < "$srcdir/258.patch"
}
pkgver() {
@@ -30,7 +34,7 @@ pkgver() {
build() {
cd "$srcdir/sc-im/src"
- make
+ make CC=gcc-8
}
package() {