summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRubin Simmons2023-10-11 21:08:37 +0200
committerRubin Simmons2023-10-11 21:08:37 +0200
commit6bec27f8e90b94f03d193c22c7bbf7db1cc5b253 (patch)
tree24e871ccfb2232f7699cb39841d701e89c447552 /PKGBUILD
downloadaur-6bec27f8e90b94f03d193c22c7bbf7db1cc5b253.tar.gz
Initial release.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 21 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..96f4df86b029
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Rubin Simons <me@rubin55.org>
+
+pkgname=scala-scala3-symlink
+pkgver=1
+pkgrel=1
+pkgdesc='Replace scala with scala3'
+arch=('any')
+url='https://scala-lang.org'
+license=('Apache')
+depends=('scala3')
+conflicts=('scala')
+
+package() {
+ install -d "$pkgdir/usr/bin"
+
+ local _file
+ for _file in scala; do
+ ln -s scala3 "$pkgdir/usr/bin/$_file"
+ done
+}
+