summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPhilipp A2018-03-03 14:00:15 +0100
committerPhilipp A2018-03-03 14:00:15 +0100
commit2af659d09400350a42343e42986eb274f4555400 (patch)
treef105e7510fae46707c09d3b85f27c525ea0787fb /PKGBUILD
parent4efbe497cd13f42ce058790ad07885eba3df011d (diff)
downloadaur-2af659d09400350a42343e42986eb274f4555400.tar.gz
v0.4.4
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 11 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a56564e77163..846ca8cdb9ba 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Phil Schaf <flying-sheep@web.de>
pkgname=scanpy
-pkgver=0.3.1
+pkgver=0.4.4
pkgrel=1
pkgdesc='Single-Cell Analysis in Python'
arch=(x86_64)
@@ -10,26 +10,28 @@ url='https://github.com/theislab/scanpy'
license=(GPL3)
depends=(
cython
- python-anndata
- python-matplotlib
- python-pandas
+ 'python-anndata>=0.5'
+ 'python-pandas>=0.21'
+ 'python-scikit-learn>=0.19.1'
python-scipy
+ python-statsmodels
+ python-matplotlib
python-seaborn
python-psutil
python-xlrd
python-h5py
- python-scikit-learn
- python-statsmodels
python-networkx
- python-igraph
python-louvain-igraph
python-natsort
python-joblib
python-profilehooks
- python-tqdm)
+)
+optdepends=(
+ 'python-umap-learn: UMAP dimension reduction'
+)
_wheel="$pkgname-$pkgver-cp36-cp36m-manylinux1_x86_64.whl"
source=("https://files.pythonhosted.org/packages/cp36/${pkgname::1}/$pkgname/$_wheel")
-md5sums=('f5fc2324b1e51ef279d8ee101494ecba')
+sha256sums=('c89b8c05c321f6e75997c6ff8172159fe773cc10bdf1fcb9c8c09596eb1aecf9')
noextract=("$_wheel")
package() {