summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPhilipp A2018-08-10 12:27:52 +0200
committerPhilipp A2018-08-10 12:27:52 +0200
commitc301437371d64a341611756b734239b5397d9ef8 (patch)
tree732df269ced198c36dabf3b296cf6ccdcd1326c4 /PKGBUILD
parentd3dbea3d559e190c8cb31b72f231ff49e7a47e44 (diff)
downloadaur-c301437371d64a341611756b734239b5397d9ef8.tar.gz
v1.2.2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 9 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 80f55ef52442..5a2c7ae4a13f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Phil Schaf <flying-sheep@web.de>
pkgname=scanpy
-pkgver=1.0.1
+pkgver=1.2.2
pkgrel=1
pkgdesc='Single-Cell Analysis in Python'
arch=(any)
@@ -9,7 +9,7 @@ provides=(scanpy python-scanpy)
url='https://github.com/theislab/scanpy'
license=(BSD)
depends=(
- 'python-anndata>=0.5.8'
+ 'python-anndata>=0.6.2'
'python-matplotlib>=2.2'
'python-pandas>=0.21'
python-scipy
@@ -21,11 +21,15 @@ depends=(
python-networkx
python-natsort
python-joblib
- python-numba)
-optdepends=(python-multicoretsne)
+ python-numba
+)
+optdepends=(
+ 'python-multicoretsne: Fast t-SNE'
+ 'python-louvain-igraph: Louvain clustering'
+)
_wheel="$pkgname-$pkgver-py3-none-any.whl"
source=("https://files.pythonhosted.org/packages/py3/${pkgname::1}/$pkgname/$_wheel")
-sha256sums=('34eac67035c33f3f392f615fe53622261a613b44d657364973a51a2c947fc94f')
+sha256sums=('0bf7f01f5a81cb2e900cc1a6854c19740b1a8de4c28781f5940cf3c0b86295c0')
noextract=("$_wheel")
package() {