summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPhilipp A2017-07-25 10:30:38 +0200
committerPhilipp A2017-07-25 10:30:38 +0200
commitd32abda6f46c5f44e2beb7ac411594dc62c444fd (patch)
tree7a2aa44b4f12b7294ddd90513cee12ad56313e86 /PKGBUILD
downloadaur-d32abda6f46c5f44e2beb7ac411594dc62c444fd.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9642f5a82fbf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Phil Schaf <flying-sheep@web.de>
+
+pkgname=scanpy
+pkgver=0.2.3
+pkgrel=1
+pkgdesc='Single-Cell Analysis in Python'
+arch=(x86_64)
+provides=(scanpy python-scanpy)
+url='https://github.com/theislab/scanpy'
+license=(GPL3)
+depends=(
+ cython
+ python-matplotlib
+ python-pandas
+ python-scipy
+ python-seaborn
+ python-psutil
+ python-xlrd
+ python-h5py
+ python-scikit-learn
+ python-statsmodels
+ python-networkx
+ python-igraph
+ python-louvain-igraph
+ python-natsort
+ python-joblib
+ python-profilehooks
+ python-tqdm)
+_wheel="$pkgname-$pkgver-cp36-cp36m-manylinux1_x86_64.whl"
+source=("https://files.pythonhosted.org/packages/cp36/${pkgname::1}/$pkgname/$_wheel")
+md5sums=('a8f89c0ece93bd628aee2c478504da04')
+noextract=("$_wheel")
+
+package() {
+ cd "$srcdir"
+ pip install --compile --no-deps --ignore-installed --root="$pkgdir" "$_wheel"
+}