summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPhilipp A2019-07-24 09:41:20 +0200
committerPhilipp A2019-07-24 09:41:20 +0200
commiteb0ce49ce337226fe5ec8c07ca6616b32a124af4 (patch)
tree04ada4932daafdd34feeae9591b57f3b96c5e654 /PKGBUILD
parent492bf3342fe321e745e0e5ccdbaae0e60427f55a (diff)
downloadaur-eb0ce49ce337226fe5ec8c07ca6616b32a124af4.tar.gz
v1.4.4
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 12 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 41526fc45077..a733194d3f9e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Philipp A. <flying-sheep@web.de>
pkgname=scanpy
-pkgver=1.4.3
+pkgver=1.4.4
pkgrel=1
pkgdesc='Single-Cell Analysis in Python'
arch=(any)
@@ -9,16 +9,17 @@ provides=(scanpy python-scanpy)
url='https://github.com/theislab/scanpy'
license=(BSD)
depends=(
- 'python-anndata>=0.6.15'
+ 'python-anndata>=0.6.22'
'python-matplotlib>=3.0'
'python-pandas>=0.21'
- python-scipy
+ 'python-scipy>=1.3'
python-seaborn
python-h5py
python-pytables
python-tqdm
- 'python-scikit-learn>=0.19.1'
- python-statsmodels
+ python-importlib-metadata
+ 'python-scikit-learn>=0.21.2'
+ 'python-statsmodels>=0.10.0'
python-patsy
python-networkx
python-natsort
@@ -26,19 +27,21 @@ depends=(
'python-numba>=0.41.0'
'python-umap-learn>=0.3.0'
)
-
optdepends=(
'python-bbknn: Batch balanced KNN (batch correction)'
'python-leidenalg: leiden community detection'
'python-multicoretsne: Fast t-SNE'
'python-louvain-igraph: Louvain clustering'
)
+makedepends=(install-wheel-scripts)
_wheel="$pkgname-$pkgver-py3-none-any.whl"
source=("https://files.pythonhosted.org/packages/py3/${pkgname::1}/$pkgname/$_wheel")
-sha256sums=('4da3b34deed62a94e6456bfff261200cd816a08cacd677369275e091ed536e6d')
+sha256sums=('f07e743ace7fa2404b4305f377338058af916f5e02d21405529f44c369c1d4fe')
noextract=("$_wheel")
package() {
- cd "$srcdir"
- pip install --compile --no-deps --ignore-installed --root="$pkgdir" "$_wheel"
+ local site="$pkgdir/usr/lib/$(readlink /bin/python3)/site-packages"
+ install -d "$site"
+ unzip "$_wheel" -d "$site"
+ install-wheel-scripts --prefix="$pkgdir/usr" "$_wheel"
}