summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMartin Doege2016-05-20 13:10:13 +0200
committerMartin Doege2016-05-20 13:10:13 +0200
commitf6468aeeaefa0d92c439a69bae523a651f439f25 (patch)
treec5c50cd7624182f6a1022253d0d4afc9045f9460 /PKGBUILD
parent0e87c26b1ea0722aae2c443f78a1ffef61e87767 (diff)
downloadaur-f6468aeeaefa0d92c439a69bae523a651f439f25.tar.gz
switch to gcc 5 from AUR due to build error with gcc 6.1.1
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 430f29c3db44..41b1d23d4822 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,11 +3,12 @@
pkgname=scid_vs_pc
pkgver=4.16
-pkgrel=2
+pkgrel=3
pkgdesc="Shane's Chess Information Database"
arch=('i686' 'x86_64')
url="http://scidvspc.sourceforge.net/"
license=('GPL2')
+makedepends=('gcc5')
depends=('snack' 'tdom-git' 'zlib')
install=$pkgname.install
conflicts=('scid')
@@ -28,7 +29,7 @@ prepare() {
# Fix for tcl 8.6
sed -i 's/8.5/8.6/g' ./configure
- ./configure BINDIR=/usr/bin/ SHAREDIR=/usr/share/scid/ TCL_VERSION="8.6" OPTIMIZE="-O2 -funroll-loops"
+ ./configure CC=gcc-5 CXX=g++-5 CPP=cpp-5 BINDIR=/usr/bin/ SHAREDIR=/usr/share/scid/ TCL_VERSION="8.6" OPTIMIZE="-O2 -funroll-loops"
}
build() {