summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorEvgeniy Alekseev2017-11-22 19:17:17 +0300
committerEvgeniy Alekseev2017-11-30 18:46:06 +0300
commite105b730355aefd34180e1cadfd4830e9fc8dda2 (patch)
tree8627c9bb786c939f3a60ce950e19227cb0b104a8 /PKGBUILD
parent914fd2d54279be669d33fbbb53042c25fa6c8019 (diff)
downloadaur-e105b730355aefd34180e1cadfd4830e9fc8dda2.tar.gz
scidavis=1.22
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 9 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f408e41980b8..d9f0bf14e184 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
# Contributor: Alexander <chronischzuspaet at gmail dot com> Kempen
pkgname=scidavis
-pkgver=1.21
+pkgver=1.22
pkgrel=1
pkgdesc="Application for Scientific Data Analysis and Visualization, fork of QtiPlot"
arch=('i686' 'x86_64')
@@ -14,11 +14,10 @@ license=('GPL')
makedepends=('boost' 'cmake')
depends=('gsl' 'glu' 'mesa' 'muparser' 'python2-pyqt4' 'shared-mime-info'
'qwt5' 'qwtplot3d')
-source=("http://prdownloads.sourceforge.net/sourceforge/scidavis/${pkgname}-${pkgver}.tar.gz"
+source=("https://prdownloads.sourceforge.net/sourceforge/scidavis/${pkgname}-${pkgver}.tar.gz"
"scidavis-python2.patch")
-md5sums=('148f73fb596f121dcfe5d929470ca97a'
- '70665013c8f456c0ebbff8373d4c8d30')
-install="${pkgname}.install"
+sha512sums=('07d94b2f8a05f28d2d461ee6109397a648bfcdcd479fca886771ad04ef8e21bfb1703891077c67a0a4a4dca5b1c31bc7029e33ebd982425a41efce42fa3319b6'
+ '3382e664df6e4f6ffc78ad974e3d27afbb6ffb091bd1b397e627cd4d0381e9c20c4c4a18f920ecb2a24e807765dd770d446197c93dc2d365acb0c722c4d0c63a')
prepare() {
cd "${pkgname}-${pkgver}"
@@ -41,5 +40,9 @@ package() {
# remove liborigin files since it uses static library
rm -rf "${pkgdir}/usr/local"
-}
+ # install translations (it looks like it does not provide target to do it)
+ install -dm755 "${pkgdir}/usr/share/scidavis/translations/"
+ find "scidavis/translations/" -name '*.qm' -type f -exec \
+ install -Dm644 {} "${pkgdir}/usr/share/scidavis/translations/" \;
+}