summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorbartus2020-06-16 17:42:19 +0200
committerbartus2020-06-16 17:56:58 +0200
commitc61e9f57e081282d0964f5e2989b1c17922e9419 (patch)
tree558bc43e4ae49872531fa1a5d65606d8a41f8316 /PKGBUILD
parent712fcb25e329f1a14f8f8ebdfa1f9c5f2725d8f6 (diff)
downloadaur-c61e9f57e081282d0964f5e2989b1c17922e9419.tar.gz
Fix gcc10 build
* tentative definitions: default to `-fno-common` https://gcc.gnu.org/gcc-10/porting_to.html#c
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD4
1 files changed, 3 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 15c527803fb3..c3c14fdc6909 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -79,7 +79,9 @@ build() {
--enable-build-localization \
--disable-static-system-lib \
--with-jdk=/usr/lib/jvm/java-8-openjdk/ \
- FFLAGS="-fallow-argument-mismatch"
+ FFLAGS="-fallow-argument-mismatch" \
+ CFLAGS="$CFLAGS -fcommon" \
+ CXXFLAGS="$CXXFLAGS -fcommon" \
make
make doc