summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlexandre Bique2015-11-19 15:22:13 +0100
committerAlexandre Bique2015-11-19 15:22:13 +0100
commit813282b810028a5b6affc71203cedb76b595e51f (patch)
tree5985429c79526b02b43e991cee2c8553277e99c6 /PKGBUILD
downloadaur-813282b810028a5b6affc71203cedb76b595e51f.tar.gz
Initial import of scissy
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD43
1 files changed, 43 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..84542811e192
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Alexandre Bique <bique.alexandre@gmail.com>
+pkgname=scissy
+pkgver=0.12.2
+pkgrel=2
+pkgdesc="Lightweight and standalone git repository server"
+arch=('i686' 'x86_64')
+url="https://githube.com/abique/scissy"
+license=('MIT')
+depends=(git sqlite3 libgit2 gnutls protobuf xz cracklib re2 mime-types)
+source=(
+ http://195.154.86.34:4242/scissy/$pkgname-$pkgver.tar.xz
+ scissy.install
+ scissy.service
+ scissy.tmpfiles
+)
+md5sums=('49c46b1fc023061dc8a58b133d7ceffb'
+ '7ccc61e12e090d4ada7240fada9aeea2'
+ '98690f1002f7d80af6cb9b939209a4dd'
+ '6c652e0203eb62fd67ed28bfa7fc9d0c')
+install=scissy.install
+backup=('etc/scissy/config.json')
+
+build() {
+ cd $startdir/src/$pkgname-$pkgver
+ rm -rf build
+ mkdir build
+ cd build
+ cmake -DCMAKE_BUILD_TYPE=release -DCMAKE_INSTALL_PREFIX=/usr ..
+ make
+}
+
+package() {
+ cd $srcdir/$pkgname-$pkgver/build
+
+ make DESTDIR=$pkgdir install
+ install -D -m644 ${srcdir}/scissy.service ${pkgdir}/usr/lib/systemd/system/scissy.service
+ install -D -m644 ${srcdir}/${pkgname}-${pkgver}/LICENSE ${pkgdir}/usr/share/licenses/scissy/LICENSE
+ install -d 755 $pkgdir/var/lib/scissy
+ install -d 750 $pkgdir/etc/scissy
+ install -Dm644 "${srcdir}"/scissy.tmpfiles "${pkgdir}"/usr/lib/tmpfiles.d/scissy.conf
+}
+
+# vim:set ts=2 sw=2 et: