summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorXiaotian Wu2022-09-10 20:12:18 +0800
committerXiaotian Wu2022-09-10 20:12:18 +0800
commite05914088f063ae9c1d10dc9bf46708eba16996c (patch)
tree2a1bb581ee9d6544dce5c5c8777492b0625fa791 /PKGBUILD
parenta76f5a2523f204a0ea8c48bbb408a1236e10bfcc (diff)
downloadaur-e05914088f063ae9c1d10dc9bf46708eba16996c.tar.gz
update scratch to 3.29.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD50
1 files changed, 25 insertions, 25 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b79099193a8d..eb3e59e32338 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,50 +1,50 @@
# Maintainer: Xiaotian Wu <yetist@gmail.com>
pkgname=scratch-desktop
-pkgver=3.28.0
+pkgver=3.29.1
pkgrel=1
pkgdesc="Create and share your own interactive stories, games, music and art"
url="https://scratch.mit.edu"
arch=('x86_64')
license=('GPL')
-depends=('c-ares' 'ffmpeg' 'gtk3' 'http-parser' 'libevent' 'libnghttp2'
- 'libxslt' 'minizip' 'nss' 're2' 'snappy')
-makedepends=('electron11')
-source=("scratch.exe::https://downloads.scratch.mit.edu/desktop/Scratch%20${pkgver}%20Setup.exe"
+depends=('c-ares' 'ffmpeg' 'gtk3' 'libevent' 'libxslt' 'minizip' 'nss' 're2'
+ 'snappy')
+makedepends=('electron19')
+options=(!strip)
+source=("scratch.exe::https://downloads.scratch.mit.edu/desktop/Scratch%20Setup.exe"
'https://scratch.mit.edu/images/download/icon.png'
'scratch-desktop.desktop'
'x-scratch.xml'
)
-sha256sums=('03037e3e4c5227c496dfc9d905e59bb3308c8ce82aec11d545cdd75145da18a2'
+sha256sums=('dfca2f1a842aea69a2b0a22ca66fa7852f86259e3da4f576f8ae7fa16f1e9134'
'5efbe1a31e973d0393631e0317f68f81d213b6c55434b9f9185a47554f23ed99'
'73d4f255aee28b9f72764a55e8711d07826e037ec624d23c8f7e7764c10475d5'
'1090a96c91f7a47801633e077717b730d636f53bac7f8958c9fc9595ee5dba7e')
-build() {
- cp -rf /usr/lib/electron11/* .
- rm $srcdir/*.dll
- rm $srcdir/*.exe
- ln -fsr electron scratch-desktop
-}
-
package() {
- install -d ${pkgdir}/usr/lib/scratch-desktop
- cp -rf locales/ resources/ swiftshader/ ${pkgdir}/usr/lib/scratch-desktop
- cp lib* ${pkgdir}/usr/lib/scratch-desktop
- cp *.pak *.bin *.dat *.json ${pkgdir}/usr/lib/scratch-desktop
- cp chrome-sandbox electron version ${pkgdir}/usr/lib/scratch-desktop
- ln -sf electron ${pkgdir}/usr/lib/scratch-desktop/scratch-desktop
+ cd "$srcdir"
- install -d ${pkgdir}/usr/share/licenses/scratch-desktop
- cp LICENSE* ${pkgdir}/usr/share/licenses/scratch-desktop
+ # Install electron
+ install -d ${pkgdir}/usr/lib/${pkgname}
+ cp -r /usr/lib/electron19/* ${pkgdir}/usr/lib/${pkgname}
+ rm -f ${pkgdir}/usr/lib/${pkgname}/resources/default_app.asar
+ # Create symlink for command
install -d ${pkgdir}/usr/bin
- ln -sf /usr/lib/scratch-desktop/scratch-desktop ${pkgdir}/usr/bin/scratch-desktop
+ ln -fs electron ${pkgdir}/usr/lib/${pkgname}/scratch-desktop
+ ln -fs /usr/lib/${pkgname}/scratch-desktop ${pkgdir}/usr/bin/scratch-desktop
+ # Install desktop file
+ install -Dm644 scratch-desktop.desktop -t ${pkgdir}/usr/share/applications/
install -Dm644 icon.png ${pkgdir}/usr/share/pixmaps/scratch-desktop.png
- install -Dm644 resources/static/assets/0fb9be3e8397c983338cb71dc84d0b25.svg ${pkgdir}/usr/share/icons/hicolor/scalable/mimetypes/scratch-sprite.svg
- install -Dm644 scratch-desktop.desktop ${pkgdir}/usr/share/applications/scratch-desktop.desktop
+ # app.asar and static
+ cd resources
+ rm -f elevate.exe
+ find . -type d -exec install -d {,"$pkgdir"/usr/lib/${pkgname}/resources/}{} \;
+ find . -type f -exec install -D {,"$pkgdir"/usr/lib/${pkgname}/resources/}{} \;
- install -Dm644 x-scratch.xml ${pkgdir}/usr/share/mime/packages/x-scratch.xml
+ # Mimetype
+ install -Dm644 static/assets/0fb9be3e8397c983338cb71dc84d0b25.svg ${pkgdir}/usr/share/icons/hicolor/scalable/mimetypes/scratch-sprite.svg
+ install -Dm644 ${srcdir}/x-scratch.xml -t ${pkgdir}/usr/share/mime/packages/
}