summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJoão Figueiredo2023-05-16 00:56:07 +0100
committerJoão Figueiredo2023-05-16 00:56:07 +0100
commit946f5e4fd98160006c9d7dfca2f3ad1c079d64d4 (patch)
tree880ccd69343a3197e3d540c743e7f3816dcbf114 /PKGBUILD
parent7e3d6dc395a89242a6e52deb22d228cec4b73e02 (diff)
downloadaur-946f5e4fd98160006c9d7dfca2f3ad1c079d64d4.tar.gz
Add missing file
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 6 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 97984c53a3b4..f79a4bdb9610 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=scrcpy-git
pkgver=2.0_r2106.gcb20bcb1
-pkgrel=1
+pkgrel=2
pkgdesc='Display and control your Android device'
arch=($CARCH)
url='https://github.com/Genymobile/scrcpy'
@@ -13,8 +13,10 @@ depends=(android-tools ffmpeg sdl2)
makedepends=(git meson)
conflicts=(${pkgname%-git})
provides=(${pkgname%-git})
-source=("git+https://github.com/Genymobile/${pkgname%-git}.git")
-sha256sums=('SKIP')
+source=("git+https://github.com/Genymobile/${pkgname%-git}.git"
+ "$url/releases/download/v${pkgver%_*}/${pkgname%-git}-server-v${pkgver%_*}")
+sha256sums=('SKIP'
+ '9e241615f578cd690bb43311000debdecf6a9c50a7082b001952f18f6f21ddc2')
pkgver() {
cd ${pkgname%-git}
@@ -27,7 +29,7 @@ build() {
arch-meson build ${pkgname%-git} \
-D b_lto=true \
-D b_ndebug=true \
- -D prebuilt_server=../$pkgname-server-v$pkgver \
+ -D prebuilt_server=../${pkgname%-git}-server-v${pkgver%_*} \
--buildtype release
ninja -C build
}