summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFrederic Bezies2019-06-24 15:49:04 +0200
committerFrederic Bezies2019-06-24 15:49:04 +0200
commit8e1f58f7dfd143d8003ba4d44948129b4d030456 (patch)
tree9df5c8dc52cf03eefcda995187e489516dca7d78 /PKGBUILD
parente9c047b89d760ec3481bf296c8eb2bba75b57e01 (diff)
downloadaur-8e1f58f7dfd143d8003ba4d44948129b4d030456.tar.gz
June 24th, 2019 update
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 6 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 80235045fcb9..e4f7432b7068 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,26 @@
-# Maintainer: Benjamin Chretien <chretien at lirmm dot fr>
+# Maintainer: Frederic Bezies <frebezies at gmail dot com>
+# Contributor: Benjamin Chretien <chretien at lirmm dot fr>
# Contributor: Adria Arrufat <swiftscythe @t gmail d@t com>
# Contributor: Gordin <9ordin @t gmail d@t com>
pkgname=screenkey-git
-pkgver=0.9.1b9d6c2
+pkgver=0.9.r42.g0c3454b
pkgrel=1
pkgdesc="Screencast tool to show your keys inspired by Screenflick, based on key-mon. Active fork with new features."
arch=('any')
-url="https://github.com/wavexx/screenkey"
+url="https://gitlab.com/wavexx/screenkey"
license=('GPL3')
depends=('python2' 'pygtk' 'libx11')
makedepends=('git' 'python2-distutils-extra' 'python2-setuptools')
optdepends=('slop' 'ttf-font-awesome')
-source=("$pkgname"::"git+https://github.com/wavexx/screenkey.git")
+source=("$pkgname"::"git+https://gitlab.com/wavexx/screenkey.git")
sha1sums=('SKIP')
conflicts=('screenkey')
replaces=('screenkey')
pkgver() {
cd "$srcdir/$pkgname"
- _rel=`git describe | sed 's/screenkey-\([0-9]\+[.0-9]\+\).*/\1/g'`
- _hash=`git log --pretty=format:'%h' -n 1`
- echo $_rel"."$_hash
+ git describe --long | sed 's/^screenkey-//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {