summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCaleb Maclennan2020-12-17 11:36:47 +0300
committerCaleb Maclennan2020-12-17 11:36:47 +0300
commit4839cd944e900aab7d919ef86a8ae96623875eea (patch)
treecf9b2c694b8dce89a7ba96be9671320ea1124838 /PKGBUILD
downloadaur-4839cd944e900aab7d919ef86a8ae96623875eea.tar.gz
Initial upload: scribl 0.2.5-1
upgpkg: scribl-git 0.2.5.r55.g260f5cf-2 Add provides/conflicts for stable package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1c777b75d932
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Caleb Maclennan <caleb@aleque.com>
+
+pkgname=scribl
+pkgver=0.2.5
+pkgrel=1
+pkgdesc='make simple instructional videos'
+arch=('x86_64')
+url="https://github.com/jneem/$pkgname"
+license=('Apache')
+depends=('gst-plugins-base-libs' 'gtk3')
+makedepends=('cargo' 'rust')
+_prefix=flatpak-v
+source=("$url/archive/$_prefix$pkgver.tar.gz")
+sha256sums=('245eb6892517f088577c2f60a8d6de753ddf45f76e60e3a02c9ba62e3087451c')
+
+prepare() {
+ cd "$pkgname-$_prefix$pkgver"
+ cargo fetch --locked
+}
+
+build() {
+ cd "$pkgname-$_prefix$pkgver"
+ cargo build --release --locked --all-features
+}
+
+check() {
+ cd "$pkgname-$_prefix$pkgver"
+ cargo test --release --locked
+}
+
+package() {
+ cd "$pkgname-$_prefix$pkgver"
+ install -Dm755 -t "$pkgdir/usr/bin" "target/release/$pkgname"
+}