summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJake2016-02-12 17:54:14 +0100
committerJake2016-02-12 17:54:14 +0100
commit2d654abff6dce5911947a3b426e32960553855d6 (patch)
tree727dfcc160ad033179da8594de8081a3fed2a991 /PKGBUILD
parent981d284daea4df56de44c21beabf6bcabbb83184 (diff)
downloadaur-2d654abff6dce5911947a3b426e32960553855d6.tar.gz
Update to 4.02
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 7 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d7eb10614721..5502a3d1d40a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,7 @@
# Maintainer: Jake <ja.ke@posteo.de>
pkgname=script-communicator
-pkgver=4_00
+_fullname=ScriptCommunicator_04_02_source
+pkgver=4.02
pkgrel=1
pkgdesc="Scriptable terminal with Serial/TCP/UDP/SPI/CAN support"
arch=('i686' 'x86_64')
@@ -9,22 +10,22 @@ license=('GPL3')
depends=('qt5-script' 'qt5-serialport')
makedepends=('qt5-tools' 'dos2unix')
-source=("http://sourceforge.net/projects/scriptcommunicator/files/Source/ScriptCommunicator_${pkgver}_source.zip"
+source=("http://sourceforge.net/projects/scriptcommunicator/files/Source/${_fullname}.zip"
"qmake.patch"
"$pkgname.desktop")
-md5sums=('ec5742772a600147ae5f78fb9dfe6fe1'
+md5sums=('38d4c47739f8468a8dd1d3504b7e4ad9'
'efe580480b123884895d7aadad495921'
'f1b6721b942570e9f5349acbef5992b0')
prepare() {
- cd "ScriptCommunicator_${pkgver}_source"
+ cd "${_fullname}"
dos2unix ScriptCommunicator.pro
patch -i "$srcdir/qmake.patch"
}
build() {
- cd "ScriptCommunicator_${pkgver}_source"
+ cd "${_fullname}"
qmake -o Makefile ScriptCommunicator.pro
make
}
@@ -32,7 +33,7 @@ build() {
package() {
install -Dm644 "$pkgname.desktop" "$pkgdir/usr/share/applications/$pkgname.desktop"
- cd "ScriptCommunicator_${pkgver}_source"
+ cd "${_fullname}"
install -Dm644 "images/main.png" "$pkgdir/usr/share/pixmaps/$pkgname.png"
mkdir -p "$pkgdir/opt/$pkgname"