summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPiotr Gorski2023-12-20 22:28:15 +0100
committerPiotr Gorski2023-12-20 22:28:15 +0100
commit6db03ded134aba22a6d020f39e629f8eecae61df (patch)
tree3e62d9c38ae054f47a9dfdf543665d7d9bac18ec /PKGBUILD
parentdfcde6349379345c65bc50ce611307a4ffee2073 (diff)
downloadaur-6db03ded134aba22a6d020f39e629f8eecae61df.tar.gz
Sync with sched-ext PKGBUILD
Signed-off-by: Piotr Gorski <lucjan.lucjanov@gmail.com>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 37a99a9a465f..ad80f6522bd8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,12 +3,12 @@
pkgname=scx-scheds-git
gitname=scx
-pkgver=0.1.2.r15.g52381a9
+pkgver=0.1.2.r24.g79b0c3e
pkgrel=1
pkgdesc="sched_ext schedulers"
arch=('x86_64')
url="https://github.com/sched-ext/scx"
-license=("GPL2")
+license=('GPL-2.0-only')
depends=('libbpf' 'bpf' 'libelf' 'zlib')
makedepends=('git' 'python' 'meson' 'clang' 'llvm-libs' 'cargo' 'rust')
source=("git+https://github.com/sched-ext/scx")
@@ -44,4 +44,5 @@ build() {
package() {
cd $gitname
meson install -C build --destdir "${pkgdir}"
+ install -Dm644 "LICENSE" "${pkgdir}/usr/share/licenses/$gitname/LICENSE"
}