summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKozeid2017-07-30 13:30:01 +0200
committerKozeid2017-07-30 13:30:01 +0200
commit8eaf1733065d3cde9489f0d8a00434ba2966237f (patch)
treef6b25b4d4c01e48252749085bacc3e04d8ebbae1 /PKGBUILD
parent7a8c05c2e2ea20ebcfcc8e3aa6024830edf6743a (diff)
downloadaur-8eaf1733065d3cde9489f0d8a00434ba2966237f.tar.gz
Fix upstream bug #1430
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 8 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0f5764862c9e..6862e46321fa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ _pkgname=sdl
pkgname=$_pkgname-hg
_pkgver=1.2.15
pkgver=1.2.15.r11056.1138bf8c009a
-pkgrel=1
+pkgrel=2
pkgdesc="A library for portable low-level access to a video framebuffer, audio output, mouse, and keyboard"
arch=('i686' 'x86_64')
url="https://www.libsdl.org"
@@ -24,7 +24,13 @@ md5sums=('SKIP')
pkgver() {
cd "SDL/"
- printf "%s.r%s.%s" "$_pkgver" "$(hg identify -n)" "$(hg identify -i)"
+ printf "%s.r%s.%s" "$_pkgver" "$(hg identify -n | sed 's/+//')" "$(hg identify -i | sed 's/+//')"
+}
+
+prepare() {
+ cd "SDL/"
+ # https://bugzilla.libsdl.org/show_bug.cgi?id=1430
+ hg backout --no-commit 5620:ad4ed9f0336f
}
build() {