summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChrister Solskogen2021-01-14 15:37:32 +0100
committerChrister Solskogen2021-01-14 15:37:32 +0100
commit9758240cec359cd402720c0b68a97053df957742 (patch)
treecd28601e4854d95b6b5dbb97abb0629877d79c7b /PKGBUILD
parent29dafc3ff9194037543755ac31def0672ec1139a (diff)
downloadaur-9758240cec359cd402720c0b68a97053df957742.tar.gz
Fix build on aarch64
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 3 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ac8ffc127ef4..e2500642377a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=sdl2-nox
pkgver=2.0.14
-pkgrel=0
+pkgrel=1
pkgdesc="A library for portable low-level access to a video framebuffer, audio output, mouse, and keyboard (Version 2) without X11 support"
arch=('x86_64' 'arm' 'armv6h' 'armv7h' 'aarch64')
url="http://www.libsdl.org"
@@ -21,10 +21,9 @@ sha512sums=('ebc482585bd565bf3003fbcedd91058b2183e333b9ea566d2f386da0298ff970645
build() {
cd "SDL2-$pkgver"
./configure --prefix=/usr \
- --enable-sdl-dlopen --enable-video-kmsdrm \
--disable-arts --disable-esd --disable-nas \
- --enable-alsa --enable-pulseaudio-shared \
- --disable-video-x11 --disable-video-opengl
+ --enable-pulseaudio-shared --enable-video-kmsdrm \
+ --without-x --disable-video-wayland --disable-video-rpi
make
}