summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSebastian Meyer2021-02-14 23:39:51 +0100
committerSebastian Meyer2021-02-14 23:41:10 +0100
commit07b68f408682347e0316819342275130e61cedd7 (patch)
tree1a2e315afb4397e7205aa75b25789c9edf4ee2ce /PKGBUILD
parentaf941b472af8e3111f07b133ad755c4507f4542b (diff)
downloadaur-07b68f408682347e0316819342275130e61cedd7.tar.gz
change source to new sdl github repos
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 81a4de614660..f6a88e83a790 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,12 +7,12 @@ conflicts=('sdl')
pkgver=r120+.dc55edfe5d2f+
pkgrel=1
pkgdesc="Provides a binary-compatible API for programs written against SDL 1.2, but it uses SDL 2.0 behind the scenes."
-url=https://hg.libsdl.org/sdl12-compat/
+url=https://github.com/libsdl-org/sdl12-compat.git
arch=('i686' 'x86_64')
license=('ZLIB')
depends=('sdl2')
-makedepends=('cmake' 'mercurial')
-source=('hg+https://hg.libsdl.org/sdl12-compat/' 'fix-cmakelists.patch' 'fix-srcdir-reference.patch')
+makedepends=('cmake' 'git')
+source=('git+https://github.com/libsdl-org/sdl12-compat.git' 'fix-cmakelists.patch' 'fix-srcdir-reference.patch')
sha256sums=('SKIP'
'6b89938e36ceafbe0e5fec87aa03606c20166890ea73320e5fabf4fd2c3ff4b5'
'e59519698276b34277a76746b84c06afe5f21037e3c4a5a8e8f913306f0bd812')
@@ -25,7 +25,7 @@ prepare() {
pkgver() {
cd sdl12-compat
- printf "r%s.%s" "$(hg identify -n)" "$(hg identify -i)"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short=7 HEAD)"
}
build() {