summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsdvcrx2022-02-24 21:07:30 +0800
committersdvcrx2022-02-24 21:11:39 +0800
commit17ba40f2baacf73ef9e686332ae4631838a61e47 (patch)
tree72df5be94e63b3bf3ed6027361be876c207bfaff /PKGBUILD
parent65585845c17394a10269340799ea13ee2c5e8de5 (diff)
downloadaur-sdlpal-git.tar.gz
Fix build broken
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 19 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 33fd86016b47..182a62d62fc4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor:: Xiaoxiao Pu <i@patme.net>
pkgname=sdlpal-git
-pkgver=20180228
+pkgver=20210211
pkgrel=1
pkgdesc="A SDL-based reimplemention of the classic Chinese-language RPG 'Xian Jian Qi Xia Zhuan'"
arch=('i686' 'x86_64')
@@ -12,12 +12,30 @@ depends=('sdl2' 'xdg-utils')
makedepends=('git' 'imagemagick')
install="sdlpal.install"
source=("sdlpal::git+https://github.com/sdlpal/sdlpal.git"
+ "SDL::git+https://github.com/sdlpal/SDL.git"
+ "googletest::git+https://github.com/sdlpal/googletest.git"
+ "mingw-std-threads::git+https://github.com/sdlpal/mingw-std-threads.git"
+ "scripts::git+https://github.com/sdlpal/scripts.git"
"sdlpal.sh"
"sdlpal.desktop")
sha256sums=('SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
'4f3b8446705af5decf25d00b54123875b9a79ae43cf70aa641c1028c29d2d547'
'47bef648b2bb5da35912d9b5bd6b4e47f0767f125465068c7b96bb437b4fb6e3')
+prepare() {
+ cd "${srcdir}/sdlpal"
+ git submodule init
+ git config submodule.3rd/SDL.url "$srcdir/SDL"
+ git config submodule.3rd/googletest.url "$srcdir/googletest"
+ git config submodule.3rd/mingw-std-threads.url "$srcdir/mingw-std-threads"
+ git config submodule.scripts.url "$srcdir/scripts"
+ git submodule update
+}
+
build() {
cd "${srcdir}/sdlpal/unix"
make