summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorXiretza2021-12-29 11:10:14 +0100
committerXiretza2021-12-29 11:10:14 +0100
commit18d2e4f17af778115b3c749bf25ff680221e3b37 (patch)
treea1d14e9fda16f4eb7348ee0cc44110418231f72f /PKGBUILD
parentcc31162ede29ae1ec84dd7f8053e6d75208bd9a1 (diff)
downloadaur-18d2e4f17af778115b3c749bf25ff680221e3b37.tar.gz
Fix compilation with boost >= 1.77
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 11 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6d09a2bb3f21..e889ad556c56 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,8 +4,8 @@
_pkgname=sdrangel
pkgname=$_pkgname-git
-pkgver=6.10.3.r0.873ec7809
-pkgrel=2
+pkgver=6.17.6.r7.5c742a873
+pkgrel=1
pkgdesc='Qt5/OpenGL SDR and signal analyzer frontend.'
arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h' 'aarch64')
url='https://github.com/f4exb/sdrangel'
@@ -41,14 +41,21 @@ optdepends=('ffmpeg: DATV demodulator'
)
provides=("$_pkgname=$pkgver")
conflicts=("$_pkgname")
-source=("git+$url")
-sha512sums=('SKIP')
+source=("git+$url" "pr-1092.patch")
+sha512sums=('SKIP'
+ '4b749458458d6b9b89f50c7fdc250fdab1320d44693a7c9c168c46277d3ec50da58043d1625d6cfefa32ba9280c0cfe9b927bc016f3b7deedce97e88f2eeca18')
pkgver() {
cd "$_pkgname"
git describe --long --tags | sed 's/^v//;s/\([^-]*-\)g/r\1/;s/-/./g;s/\.rc./rc/g'
}
+prepare() {
+ cd "$_pkgname"
+
+ patch -p1 < "$srcdir/pr-1092.patch"
+}
+
build() {
# https://bugs.gentoo.org/704322
export CXXFLAGS="$CXXFLAGS -fpermissive"