summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorOndřej Hruška2015-06-14 21:20:20 +0200
committerOndřej Hruška2015-06-14 21:20:20 +0200
commit25f11f389531f2d9e98deafdc9233dab00d4576b (patch)
treefbf0e58401860303bd38e79ccd8cfecfdeea949f /PKGBUILD
downloadaur-25f11f389531f2d9e98deafdc9233dab00d4576b.tar.gz
import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fad6beddd3af
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Ondrej Hruska <ondra@ondrovo.com>
+
+_pkgname="sdscp"
+pkgname="sdscp-git"
+
+pkgver=1.3.3
+pkgrel=1
+
+pkgdesc="External preprocessor and pre-compiler for SDS-C (by AN-D.cz)"
+arch=("any")
+url="https://github.com/MightyPork/sdscp"
+license=("GPL2")
+
+depends=("python3")
+
+makedepends=("git")
+
+source=("git+https://github.com/MightyPork/sdscp.git")
+provides=("sdscp")
+replaces=("sdscp")
+md5sums=("SKIP")
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ git describe --tags | sed "s|-|.|g"
+}
+
+package() {
+ # install license
+ install -Dm 644 "${srcdir}/${_pkgname}/LICENSE" "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
+
+ # install files in /usr/share
+ mkdir "${pkgdir}/usr/share/${_pkgname}/"
+
+ cp -pR "${srcdir}/${_pkgname}"/* "${pkgdir}/usr/share/${_pkgname}/"
+
+ # install link in /usr/bin
+ mkdir -p "${pkgdir}/usr/bin/"
+ ln -s "/usr/share/${_pkgname}/sdscp" "${pkgdir}/usr/bin/sdscp"
+} \ No newline at end of file