summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoreolianoe2017-05-14 23:45:45 +0200
committereolianoe2017-05-14 23:45:45 +0200
commit7e5e02302fd4abb0654336e42592b2e1c3ac5ffb (patch)
treee42177b6d8ead5104b9dbaa83cc78048bd80d3ed /PKGBUILD
parent2e534d7e21ff042a115d70c6c0c97378c8a2ae9b (diff)
downloadaur-7e5e02302fd4abb0654336e42592b2e1c3ac5ffb.tar.gz
updpkg: 6.0.6
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 5 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7e5caa20df9e..6b3cbfdcee2d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
# Contributor: Aaron Lindsay <aaron@aclindsay.com>
pkgname=seafile
-pkgver=6.0.4
-pkgrel=2
+pkgver=6.0.6
+pkgrel=1
pkgdesc="Seafile is an online file storage and collaboration tool"
arch=('i686' 'x86_64' 'armv7h' 'armv6h' 'aarch64')
url="https://github.com/haiwen/${pkgname}"
@@ -12,18 +12,15 @@ license=('GPL2')
depends=("ccnet" "fuse" "python2" "sqlite")
makedepends=("vala" "intltool")
source=("seafile-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz"
- "libseafile.in.patch"
- "openssl-1.0.patch")
-sha256sums=('b3919bff1e0f974483df129e500868332e752dec6380556839e006bf9d5b425e'
- 'a2d7f7cf0c59aba97650af62b3cefd0ceb71a1007c34d9369a88e5769c7f6076'
- 'de1b28f5ed08dfc5722f4dfda85f4ecb4a4fb707089adb612fea51d7f51e7f1f')
+ "libseafile.in.patch")
+sha256sums=('3f4e25211c301d18fa0ff0be0f9ba0fcbc2649a5092b10cdb960a78be2062aed'
+ 'a2d7f7cf0c59aba97650af62b3cefd0ceb71a1007c34d9369a88e5769c7f6076')
provides=('seafile-client-cli')
prepare () {
cd "${srcdir}/seafile-${pkgver}"
patch -p1 -i "${srcdir}/libseafile.in.patch"
- patch -p0 -i "${srcdir}"/openssl-1.0.patch
# Fix all script's python 2 requirement
grep -s -l -r '#!/usr/bin/env python' "${srcdir}/seafile-${pkgver}" \
@@ -33,8 +30,6 @@ prepare () {
build() {
cd "$srcdir/seafile-${pkgver}"
- export PKG_CONFIG_PATH=/usr/lib/openssl-1.0/pkgconfig
-
./autogen.sh
./configure \