summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJoffrey2020-01-16 23:45:42 +0100
committerJoffrey2020-01-16 23:45:42 +0100
commitbb72d7e7a38cfa19579cfdf5cbdd2ab956e53b6f (patch)
tree28f8775e59398702215673d7a6e663ada1f65c5f /PKGBUILD
parent77e395da66cad1bbb610132eaae2702be7b569c6 (diff)
downloadaur-bb72d7e7a38cfa19579cfdf5cbdd2ab956e53b6f.tar.gz
updpkg: 7.0.5
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD79
1 files changed, 45 insertions, 34 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 036e59265a28..3952137ad771 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,52 +1,63 @@
-# Maintainer: eolianoe <eolianoe [at] gmail [DoT] com>
+# Maintainer: Joffrey <j-off@live.fr>
+# Contributor: eolianoe <eolianoe [at] gmail [DoT] com>
# Contributor: Edvinas Valatka <edacval@gmail.com>
# Contributor: Aaron Lindsay <aaron@aclindsay.com>
pkgname=seafile
-pkgver=7.0.4
+pkgver=7.0.5
pkgrel=1
-pkgdesc="Seafile is an online file storage and collaboration tool"
+pkgdesc='An online file storage and collaboration tool'
arch=('i686' 'x86_64' 'armv7h' 'armv6h' 'aarch64')
-url="https://github.com/haiwen/${pkgname}"
+url="https://github.com/haiwen/$pkgname"
license=('GPL2')
-depends=("ccnet-server" "libsearpc" "libevent"
- "fuse" "python2" "python2-future" "sqlite")
-makedepends=("vala" "intltool")
-conflicts=("seafile-server")
-source=("seafile-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz"
- "libseafile.in.patch"
- "seaf-cli@.service")
-sha256sums=('75f98e1c08939b933134fa998f21fafc208aa02d980f5b8624dbf02d7b0cae13'
- 'a2d7f7cf0c59aba97650af62b3cefd0ceb71a1007c34d9369a88e5769c7f6076'
- 'c37510109c1de64c774896df39aece240c056b54414d2119fca01860211156ba')
+depends=(
+ 'ccnet-server'
+ 'libsearpc'
+ 'libevent'
+ 'fuse'
+ 'python2'
+ 'python2-future'
+ 'sqlite'
+)
+makedepends=(
+ 'vala'
+ 'intltool'
+)
+conflicts=('seafile-server')
+source=(
+ "seafile-$pkgver.tar.gz::$url/archive/v${pkgver}.tar.gz"
+ "seaf-cli@.service"
+)
+sha256sums=(
+ '19b353279e20f84af94b08c62b948748bda8cd69eeb980c9fc124ea9a9a5f825'
+ 'c37510109c1de64c774896df39aece240c056b54414d2119fca01860211156ba'
+)
provides=('seafile-client-cli')
-prepare () {
- cd "${srcdir}/seafile-${pkgver}"
+prepare() {
+ cd "$srcdir/seafile-$pkgver"
+ sed -i 's|(DESTDIR)@prefix@|@prefix@|' './lib/libseafile.pc.in'
- patch -p1 -i "${srcdir}/libseafile.in.patch"
-
- # Fix all script's python 2 requirement
- grep -s -l -r '#!/usr/bin/env python' "${srcdir}/seafile-${pkgver}" \
- | xargs sed -i -e 's|#!/usr/bin/env python|#!/usr/bin/env python2|g'
+ # Fix all script's python 2 requirement
+ shebang='#!/usr/bin/env python'
+ grep -s -l -r "$shebang" | xargs sed -i "1 s|$shebang|${shebang}2|"
}
build() {
- cd "$srcdir/seafile-${pkgver}"
-
- ./autogen.sh
-
- ./configure \
- --enable-console \
- --prefix=/usr \
- PYTHON=/usr/bin/python2
-
- make
+ cd "$srcdir/seafile-$pkgver"
+ ./autogen.sh
+ ./configure \
+ --enable-console \
+ --prefix=/usr \
+ PYTHON=/usr/bin/python2
+ make
}
package() {
- cd "${srcdir}/seafile-${pkgver}"
+ cd "$srcdir/seafile-$pkgver"
+ make DESTDIR="$pkgdir" install
- make DESTDIR="${pkgdir}" install
- install -Dm644 "${srcdir}"/seaf-cli@.service "${pkgdir}"/usr/lib/systemd/system/seaf-cli@.service
+ install -Dm644 \
+ "$srcdir/seaf-cli@.service" \
+ "$pkgdir/usr/lib/systemd/system/seaf-cli@.service"
}