summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoredac val2015-08-18 10:10:31 +0300
committerEdvinas Valatka2015-11-04 19:25:47 +0200
commitc628e3c5a35683ca9a267a35dabf4ed1b43a4d6a (patch)
treecc3d050db06f36610cfab9670012cf70699641ec /PKGBUILD
parent81e05ca486d365f958df8fcc74325e22a7325d42 (diff)
downloadaur-c628e3c5a35683ca9a267a35dabf4ed1b43a4d6a.tar.gz
Cleanup
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 5 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6f48f33d56f9..61df4dc13d1e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,5 @@
-# Maintainer: Moritz Maxeiner <moritz@ucworks.org>
-
# Contributor: localizator <localizator@ukr.net>
+# Maintainer: Edvinas Valatka <edacval@gmail.com>
pkgname=seafile-client
pkgver=4.3.4
@@ -9,23 +8,22 @@ pkgdesc="Seafile is an online file storage and collaboration tool. This is seafi
arch=('i686' 'x86_64')
url="https://github.com/haiwen/seafile-client/"
license=('Apache')
-depends=('seafile-shared>=4.3.4' 'qt4' 'qtwebkit')
+depends=('seafile-shared>=4.4.2' 'qt4' 'qtwebkit')
makedepends=('cmake')
-optdepends=()
options=('!libtool' '!emptydirs')
install=seafile-client.install
-source=("https://github.com/haiwen/seafile-client/archive/v${pkgver}.tar.gz")
+source=("${pkgname}-v${pkgver}.tar.gz::https://github.com/haiwen/${pkgname}/archive/v${pkgver}.tar.gz")
build ()
{
- cd "$srcdir/seafile-client-${pkgver}"
+ cd "$srcdir/${pkgname}-${pkgver}"
cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr .
make
}
package ()
{
- cd "${srcdir}/seafile-client-${pkgver}"
+ cd "${srcdir}/${pkgname}-${pkgver}"
make DESTDIR="${pkgdir}/" install
}
md5sums=('137a474aca893cec66e5f1e87dc2d0d1')