summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJosef Vybíhal2022-07-27 10:44:32 +0200
committerJosef Vybíhal2022-07-27 10:44:32 +0200
commit9a2eddb76f131fd718d366a95a003fd955f43782 (patch)
treeebcead8c0996abf03154a815f731dd6a26f8da38 /PKGBUILD
parent1837503e1ad1e97064a2d9cc09bd797d534970e8 (diff)
downloadaur-seahorse-git.tar.gz
Different way to strip git from pkgname
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 2 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e454bb575c71..4d3676451c07 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -18,7 +18,6 @@ conflicts=('seahorse')
provides=('seahorse')
makedepends=(libldap yelp-tools gobject-introspection vala git meson)
provides=(x11-ssh-askpass)
-_pkgname=seahorse
# Tag: 3.30.0: 7e0535880a2010df356d9c468c68cdcb77b45431
#_commit=7e0535880a2010df356d9c468c68cdcb77b45431
#source=("git+https://gitlab.gnome.org/GNOME/seahorse.git#commit=$_commit")
@@ -27,12 +26,12 @@ source=("git+https://gitlab.gnome.org/GNOME/seahorse.git")
sha256sums=('SKIP')
pkgver() {
- cd ${_pkgname}
+ cd ${pkgname%-git}
git describe --tags | sed 's/-/+/g'
}
prepare() {
- cd ${_pkgname}
+ cd ${pkgname%-git}
}
build() {