summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJoffrey Darcq2018-02-26 12:08:36 +0100
committerJoffrey Darcq2018-02-26 12:08:36 +0100
commit4236e3b6bbc22714eb79373dc56d55f92ba769cf (patch)
tree4d602f9f4d1d6ff73d0bb0910a046db5210d4b43 /PKGBUILD
parent7e023c72e93b0fa8483c7520f9eb448e2da747c6 (diff)
downloadaur-4236e3b6bbc22714eb79373dc56d55f92ba769cf.tar.gz
Update depends
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD52
1 files changed, 35 insertions, 17 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 220fac151f8b..ba6e4c9d6dce 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,22 +5,27 @@
pkgname='seahub'
pkgver=6.2.5
-pkgrel=5
+pkgrel=6
pkgdesc='The web frontend for seafile server'
arch=('i686' 'x86_64' 'armv7h' 'armv6h' 'aarch64')
url="https://github.com/haiwen/${pkgname}"
-license=('Apache' 'PSF' 'MIT' 'BSD' 'GPL')
-depends=("seafile-server=${pkgver}" 'libmemcached' 'libmariadbclient')
-optdepends=('memcached' 'mariadb')
-makedepends=('python2-virtualenv')
+license=('custom:Apache PSF MIT BSD GPL')
+depends=("seafile-server=${pkgver}" 'libmemcached' 'freetype2' 'openjpeg2')
+optdepends=('mariadb: For use MySQL databases'
+ 'memcached: For better caching performance'
+ 'ffmpeg: For video thumbnails')
+makedepends=('python2-virtualenv' 'git')
changelog="ChangeLog"
source=("${pkgname}-${pkgver}-server.tar.gz::${url}/archive/v${pkgver}-server.tar.gz")
sha256sums=('80a7a1cadde8e8e570bdc454bc4a4902ebcace97b347f9eef701b5ab02742039')
options=("!strip")
-prepare () {
+prepare() {
cd "${srcdir}/${pkgname}-${pkgver}-server"
+ # Remove useless files and directories
+ rm -rf './'{*test*,*sh*,CONTRIBUTORS,HACKING,Makefile,README.*,pylintrc*}
+
# Use python lib seahub interpreter for all scripts
grep -s -l -r '#!/usr/bin/env python' "./" \
| xargs sed -i -e '1 s|#!/usr/bin/env python|#!/usr/lib/seahub/bin/python2|'
@@ -32,6 +37,19 @@ prepare () {
echo 'pylibmc' # Memcached support
echo 'django-pylibmc' # Memcached support
} >> "./requirements.txt"
+
+ # Prepare License
+ cat './LICENSE-'* >> './LICENSE.txt' && rm -f './LICENSE-'*
+}
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}-server/"
+
+ printf 'Compile seahub locales...'
+ for locale in ./locale/*/LC_MESSAGES/*.po; do
+ msgfmt -o "${locale%.po}.mo" "${locale}"
+ done
+ printf 'done.\n'
}
package() {
@@ -41,32 +59,32 @@ package() {
install -dm755 "${pkgdir}/usr/share/seafile-server/seahub"
cp -r -p "./"* "${pkgdir}/usr/share/seafile-server/seahub/"
+ install -Dm644 './LICENSE.txt' "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+
# Create VirtualEnv
venv="${pkgdir}/usr/lib/seahub"
virtualenv2 --no-wheel --system-site-packages "${venv}"
source "${venv}/bin/activate" # Activates the VirtualEnv
- # Fix subprocess exception if gunicorn is already installed
- printf 'Installing gunicorn...'
- pip2 install --isolated --no-compile --upgrade --force-reinstall gunicorn > /dev/null && \
+ # Fix modules missing
+ printf 'Installing gunicorn, six...'
+ pip2 install --isolated --no-compile --upgrade --force-reinstall 'gunicorn' 'six' > /dev/null
printf 'done.\n'
# Install requirements
pip2 install --isolated --no-compile -r "./requirements.txt"
-
+
deactivate # Deactivate VirtualEnv
- # Use relative path
- virtualenv2 --relocatable "${venv}"
+ virtualenv2 --relocatable "${venv}" # Use relative path
- # Recompile all .pyc files in venv. Not stricly required
- # But useful for printing valid source file paths in case of python exceptions.
- # Requires minimum 1GB RAM, comment next two commands in case of < 1GB RAM
+ # Recompile .py for printing valid file paths in case of python exceptions.
+ # Requires minimum 1GB RAM, comment next commands in case of < 1GB RAM
printf "Compile all .py in %s/..." "${venv}/bin"
python2 -m compileall \
-q -f -d "${venv#$pkgdir}/bin" \
- -- "${venv}/bin" && \
+ -- "${venv}/bin"
printf 'done.\n'
# _gaiohttp.py excluded due to https://github.com/benoitc/gunicorn/issues/810
@@ -74,6 +92,6 @@ package() {
python2 -m compileall \
-q -f -d "${venv#$pkgdir}/lib/python2.7" \
-x '.*/gunicorn/workers/_gaiohttp.py' \
- -- "${venv}/lib/python2.7" && \
+ -- "${venv}/lib/python2.7"
printf 'done.\n'
}