summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJoffrey2021-12-17 13:07:40 +0100
committerJoffrey Darcq2021-12-17 13:10:45 +0100
commitacaef7ab84b123cf9d6db40939bdc521ab8e73eb (patch)
tree61902f03ace60e820a7ebc1cb6b5e69fcb4f0c0c /PKGBUILD
parent67ccbf551728a99b7220b161991cf63b8e147abb (diff)
downloadaur-acaef7ab84b123cf9d6db40939bdc521ab8e73eb.tar.gz
updpkg: 9.0.2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 21 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0261da480fcd..8b0bdca3e498 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# Contributor: Aaron Lindsay <aaron@aclindsay.com>
pkgname=seahub
-pkgver=8.0.8
+pkgver=9.0.2
pkgrel=1
pkgdesc='The web frontend for seafile server'
arch=('any')
@@ -12,15 +12,17 @@ url='https://github.com/haiwen/seahub'
license=('Apache')
depends=(
"seafile-server>=$pkgver"
+ 'python-django'
'python-future'
'python-django-statici18n'
- 'python-django-post-office'
'gunicorn'
'python-mysqlclient'
+ 'python-django-picklefield'
'python-openpyxl'
'python-qrcode'
'python-django-formtools'
'python-django-simple-captcha'
+ 'python-django-rest-framework'
'python-dateutil'
'python-requests'
'python-pillow'
@@ -29,33 +31,28 @@ depends=(
'python-requests-oauthlib'
'python-django-ranged-response'
'python-chardet'
+ 'python-cffi'
)
optdepends=(
+ 'python-pymysql: Installation script'
+ 'python-pysaml2: SSO support'
+ 'python-django-saml2: SSO support'
'python-wsgidav-seafile: Webdav support'
'python-django-pylibmc: Memcached support'
'ffmpeg: For video thumbnails'
)
# Outdated Python modules, but required by Seahub
_thirdpart=(
- 'django-2.2.14'
- 'django-picklefield-2.1.1'
- 'django-rest-framework-3.11.1'
'django-webpack-loader-0.7.0'
)
source=(
"$pkgname-$pkgver-server.tar.gz::$url/archive/v$pkgver-server.tar.gz"
- "${_thirdpart[0],,}.tar.gz::https://github.com/django/${_thirdpart[0]%-*}/archive/${_thirdpart[0]##*-}.tar.gz"
- "${_thirdpart[1],,}.tar.gz::https://github.com/gintas/${_thirdpart[1]%-*}/archive/v${_thirdpart[1]##*-}.tar.gz"
- "${_thirdpart[2],,}.tar.gz::https://github.com/encode/${_thirdpart[2]%-*}/archive/${_thirdpart[2]##*-}.tar.gz"
- "${_thirdpart[3],,}.tar.gz::https://github.com/django-webpack/${_thirdpart[3]%-*}/archive/${_thirdpart[3]##*-}.tar.gz"
+ "${_thirdpart[0],,}.tar.gz::https://github.com/django-webpack/${_thirdpart[0]%-*}/archive/${_thirdpart[0]##*-}.tar.gz"
'seahub@.service'
'nginx.example.conf'
)
sha256sums=(
- '855429dffa7b41728c7b69f7ccde059529139e448ff08b4fea0fe03d032a172d'
- '52590ea1a39713cb87cc1f93588867049a84d1985b215ed3884695bae01469ec'
- '5985205ec990ad1319e6d238616284b342f018d41a30dc089b76349fb17b15ae'
- '513c0da69619e76715a4ac9149d7715751b9c4820a29476cb143f2bb6b5a3d11'
+ '1c13800c3e2db89ff5f5eae26e7fd1cabaa3bcfe702c3c58062e34437d308cb8'
'fef6b13bbd61d682e12f3bd73bb7ac1c398dd0dea22ef2cf34309c6d1078b0d1'
'67bb375871ce908b48bef53277284c9d8f80ee2e733efc89cb66d987647195e4'
'461591ba500d012523d6fdecbcc230461f6fd8d708b92eefdedc8b93b1542171'
@@ -69,7 +66,13 @@ prepare() {
rm -rf \
./{CONTRIBUTORS,HACKING,Makefile} \
./{*test*,*dev*,*sh*,README*,pylintrc*,LICENSE*} \
- "$(find . -name \*.pyc)"
+ ./scripts/{build,pro.py,*.{md,conf}}
+ find . -type f \( -name '*.pyc' -o -name '.git*' \) -delete
+
+ # Fix paths to Gunicorn
+ sed -e 's|gunicorn_exe=.*|gunicorn_exe=/usr/bin/gunicorn|g' \
+ -e 's|thirdpart/bin/gunicorn|$gunicorn_exe|g' \
+ -i ./scripts/seahub.sh
sed -i -E "/SEAFILE_VERSION/s/[0-9.]+/$pkgver/" ./seahub/settings.py
}
@@ -87,7 +90,9 @@ package() {
cd "$srcdir/seahub-$pkgver-server/"
install -dm755 "$pkgdir/usr/share/seafile-server/seahub"
- cp -r -p "./"* "$pkgdir/usr/share/seafile-server/seahub/"
+ cp -rp ./* "$pkgdir/usr/share/seafile-server/seahub"
+ mv "$pkgdir/usr/share/seafile-server/seahub/scripts/"* \
+ "$pkgdir/usr/share/seafile-server"
# Install third part
for thirdpart in "${_thirdpart[@]}"; do
@@ -100,7 +105,7 @@ package() {
rm -rf "$pkgdir"/usr/{bin,share/seafile-server/"$pkgname"/thirdpart/*.egg-info}
python -m compileall -f -j 0 -o 1 \
- -s "$pkgdir" -p '/' "$pkgdir/usr/share/seafile-server/seahub"
+ -s "$pkgdir" -p / "$pkgdir/usr/share/seafile-server/seahub"
install -Dm644 \
"$srcdir/seahub@.service" \