summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJoffrey2023-12-23 13:05:09 +0100
committerJoffrey2023-12-23 13:05:09 +0100
commite08717ff0db7d8009cfe061e2a8f1fa30f3e8e14 (patch)
tree8b0c0909391863cfd249c5de67d5524e7acc3938 /PKGBUILD
parentdcda40c86732363ec2d75ccac170a6e6740ffb37 (diff)
downloadaur-e08717ff0db7d8009cfe061e2a8f1fa30f3e8e14.tar.gz
updpkg: 11.0.3
Remove Fix_Pillow_ANTIALIAS_deprecation.diff Add python-ldap and python-django-saml2 deps Use Django official package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 6 insertions, 26 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a4fa1088d54d..c7fa0c4ba02f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,8 +4,8 @@
# Contributor: Aaron Lindsay <aaron@aclindsay.com>
pkgname=seahub
-pkgver=10.0.1
-pkgrel=2
+pkgver=11.0.3
+pkgrel=1
pkgdesc='The web frontend for seafile server'
arch=('any')
url='https://github.com/haiwen/seahub'
@@ -19,6 +19,7 @@ depends=(
'python-django-picklefield'
'python-django-formtools'
'python-django-simple-captcha'
+ 'python-django-saml2'
'python-django-rest-framework'
'python-dateutil'
'python-pyjwt'
@@ -31,44 +32,33 @@ depends=(
'python-qrcode'
'python-pillow'
'python-chardet'
- 'python-openpyxl'
'python-cffi'
+ 'python-openpyxl'
'python-markdown'
'python-bleach'
+ 'python-ldap'
)
optdepends=(
'python-pymysql: Installation script'
- 'python-pysaml2: SSO support'
- 'python-django-saml2: SSO support'
'python-wsgidav-seafile: Webdav support'
'python-django-pylibmc: Memcached support'
'ffmpeg: For video thumbnails'
)
-# Outdated Python modules, but required by Seahub
-_thirdpart=(
- 'django-3.2.18'
-)
source=(
"$pkgname-$pkgver-server.tar.gz::$url/archive/v$pkgver-server.tar.gz"
- "${_thirdpart[0],,}.tar.gz::https://github.com/django/${_thirdpart[0]%-*}/archive/${_thirdpart[0]##*-}.tar.gz"
'seahub@.service'
'nginx.example.conf'
- 'Fix_Pillow_ANTIALIAS_deprecation.diff'
)
sha256sums=(
- '4df0697ea9ed62ceb53f2f17dcc35f4abf2b69f276c87c913bb30a72f6007cb2'
- 'b7894330d7fd9a268cf5b430b09db111508c5f7a98fa4ffc8c0b88aada9b6dbf'
+ '0dd8115f0e82079d06c6a6c01edb19f34ef211438b67059436e2e57362e548c8'
'67bb375871ce908b48bef53277284c9d8f80ee2e733efc89cb66d987647195e4'
'461591ba500d012523d6fdecbcc230461f6fd8d708b92eefdedc8b93b1542171'
- '4672793c24577875446b62766af37aed25169f0b764ea14c97c1ab0942403ec0'
)
options=('!strip')
prepare() {
cd "$srcdir/$pkgname-$pkgver-server"
- patch -p1 -i "$srcdir/Fix_Pillow_ANTIALIAS_deprecation.diff"
-
# Remove useless files and directories
rm -rf \
./{CONTRIBUTORS,HACKING,Makefile} \
@@ -101,16 +91,6 @@ package() {
mv "$pkgdir/usr/share/seafile-server/seahub/scripts/"* \
"$pkgdir/usr/share/seafile-server"
- # Install third part
- for thirdpart in "${_thirdpart[@]}"; do
- cd "$srcdir/$thirdpart"
- python setup.py install \
- --root="$pkgdir/" \
- --install-lib="usr/share/seafile-server/$pkgname/thirdpart" \
- --optimize=0
- done
- rm -rf "$pkgdir"/usr/{bin,share/seafile-server/"$pkgname"/thirdpart/*.egg-info}
-
python -m compileall -f -j 0 -o 1 \
-s "$pkgdir" -p / "$pkgdir/usr/share/seafile-server/seahub"