summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJoffrey2023-04-14 18:04:40 +0200
committerJoffrey2023-04-14 18:04:40 +0200
commitfb9a1228af9960eed121b9956436b6baf0d72a5d (patch)
treec9ff5e77cda5615308adf77e34ffbbeb8858316b /PKGBUILD
parent3c707ad930e0b63202bdcc2463a7a02b91e4c4eb (diff)
downloadaur-fb9a1228af9960eed121b9956436b6baf0d72a5d.tar.gz
updpkg: 10.0.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 13 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e152f3f6cc84..e6af446fde62 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# Contributor: Aaron Lindsay <aaron@aclindsay.com>
pkgname=seahub
-pkgver=9.0.10
+pkgver=10.0.1
pkgrel=1
pkgdesc='The web frontend for seafile server'
arch=('any')
@@ -12,25 +12,26 @@ url='https://github.com/haiwen/seahub'
license=('Apache')
depends=(
"seafile-server>=$pkgver"
+ 'python-setuptools'
'python-django'
- 'python-future'
'python-django-statici18n'
- 'gunicorn'
- 'python-mysqlclient'
+ 'python-django-webpack-loader'
'python-django-picklefield'
- 'python-openpyxl'
- 'python-qrcode'
'python-django-formtools'
'python-django-simple-captcha'
'python-django-rest-framework'
'python-dateutil'
- 'python-requests'
- 'python-pillow'
'python-pyjwt'
'python-pycryptodome'
+ 'python-requests'
'python-requests-oauthlib'
- 'python-django-ranged-response'
+ 'python-future'
+ 'gunicorn'
+ 'python-mysqlclient'
+ 'python-qrcode'
+ 'python-pillow'
'python-chardet'
+ 'python-openpyxl'
'python-cffi'
'python-markdown'
'python-bleach'
@@ -45,20 +46,17 @@ optdepends=(
)
# Outdated Python modules, but required by Seahub
_thirdpart=(
- 'django-3.2.16'
- 'django-webpack-loader-0.7.0'
+ 'django-3.2.18'
)
source=(
"$pkgname-$pkgver-server.tar.gz::$url/archive/v$pkgver-server.tar.gz"
"${_thirdpart[0],,}.tar.gz::https://github.com/django/${_thirdpart[0]%-*}/archive/${_thirdpart[0]##*-}.tar.gz"
- "${_thirdpart[1],,}.tar.gz::https://github.com/django-webpack/${_thirdpart[1]%-*}/archive/${_thirdpart[1]##*-}.tar.gz"
'seahub@.service'
'nginx.example.conf'
)
sha256sums=(
- '3a885a8a1894d003264a1d9bbdbae6593a513f7654b7d750171bab1086b8f79d'
- '21f3f72c7a6e938315f437d7225e91c4fe1d8b29d2d2428aaeb86341b9e88863'
- 'fef6b13bbd61d682e12f3bd73bb7ac1c398dd0dea22ef2cf34309c6d1078b0d1'
+ '4df0697ea9ed62ceb53f2f17dcc35f4abf2b69f276c87c913bb30a72f6007cb2'
+ 'b7894330d7fd9a268cf5b430b09db111508c5f7a98fa4ffc8c0b88aada9b6dbf'
'67bb375871ce908b48bef53277284c9d8f80ee2e733efc89cb66d987647195e4'
'461591ba500d012523d6fdecbcc230461f6fd8d708b92eefdedc8b93b1542171'
)