summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorphanium2023-07-08 16:39:58 +0800
committerphanium2023-07-08 16:39:58 +0800
commit420e843ff5b93f4a2db6fdbd5ba081b67654920d (patch)
treea19f0dd6eb57c44c4a1efac6968b6dff499bc566 /PKGBUILD
downloadaur-420e843ff5b93f4a2db6fdbd5ba081b67654920d.tar.gz
init commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2555ea685da6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: phanium <$(echo bnhoc2R1QHFxLmNvbQo= | base64 -d)>
+pkgname=sealcrypto-git
+pkgver=v4.1.1.r0.g206648d
+pkgrel=1
+pkgdesc='Microsoft library for fully homomorphic encryption'
+arch=('x86_64')
+url="https://github.com/Microsoft/SEAL"
+license=('MIT')
+makedepends=('git' 'cmake')
+source=("${pkgname}::git+${url}")
+sha256sums=('SKIP')
+conflicts=("sealcrypto")
+
+pkgver() {
+ cd ${srcdir}/${pkgname}
+ git describe --long --tags --abbrev=7 | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd ${srcdir}
+ cmake -B build -S ${pkgname} \
+ -DCMAKE_BUILD_TYPE='None' \
+ -DCMAKE_INSTALL_PREFIX=/usr
+ cmake --build build
+}
+
+package() {
+ install -m644 -D ${srcdir}/${pkgname}/LICENSE \
+ ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+ DESTDIR="${pkgdir}" cmake --install build
+}