summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMauro Santos2015-10-19 09:53:16 +0100
committerMauro Santos2015-10-19 09:53:16 +0100
commit6d35bcf544364299973c274d101ff6005e7d6f4f (patch)
treef4a496819a95d03d96e96d239d702cc65f1af153 /PKGBUILD
parentbfa23e450059b6457c14366927cbd5673215cab7 (diff)
downloadaur-6d35bcf544364299973c274d101ff6005e7d6f4f.tar.gz
Correct install message to reflect the fact that libata.allow_tpm
cannot be changed on a running system. Add a mkinitcpio hook and configuration file to allow the creation of a linuxpba initramfs that can be used in a PBA image to unlock the SED.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 19 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index df12c38c039e..7511bff41341 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,24 @@
pkgname=sedutil
pkgver=1.00
-pkgrel=2
+pkgrel=3
pkgdesc="TCG OPAL 2.00 SED Management Program"
arch=('i686' 'x86_64')
url="https://github.com/Drive-Trust-Alliance/sedutil"
license=('GPL3')
install=sedutil.install
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/Drive-Trust-Alliance/${pkgname}/archive/${pkgver}.tar.gz")
-sha256sums=('7d9c8b3eb408de8218e8bd29f118a8956157ca6e80fb0d8782074302cc13d2e8')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/Drive-Trust-Alliance/${pkgname}/archive/${pkgver}.tar.gz"
+ 'extlinux.conf'
+ 'mklinuxpba'
+ 'linuxpba.conf'
+ 'linuxpba.hook'
+ 'linuxpba.install')
+sha256sums=('7d9c8b3eb408de8218e8bd29f118a8956157ca6e80fb0d8782074302cc13d2e8'
+ '6d528877c70b24367833653f5a7cc004a6b5aad8729b661d8c3fda3f1ee7d4ff'
+ '084df0ee2bfc14a4450942b4de4b7f697346fbae9b1c1b7193ce1db66e4dd7e7'
+ 'be7790a69eb4e82a84c690e41cdff04f08a0a61a30a6c28b88df916e3fb59950'
+ 'd9a7b66d8365e7f4eb0233b30c0ab70b5e978f6554960bf12994a1f0910c1447'
+ '7c32370c3405fc33359c1fc5bb243f387c71ca454e9da88348669fd383f04558')
PKGEXT='.pkg.tar'
CPPFLAGS="$CPPFLAGS -O2"
@@ -25,4 +35,10 @@ package() {
install -Dm755 "linux/CLI/dist/Release_$CARCH/GNU-Linux-x86/sedutil-cli" "${pkgdir}/usr/bin/sedutil-cli"
install -Dm644 "linux/PSIDRevert_LINUX.txt" "${pkgdir}/usr/share/doc/${pkgname}/PSIDRevert.txt"
install -Dm755 "LinuxPBA/dist/Release_$CARCH/GNU-Linux-x86/linuxpba" "${pkgdir}/usr/bin/linuxpba"
+ install -Dm755 "${srcdir}/mklinuxpba" "${pkgdir}/usr/bin/mklinuxpba"
+
+ install -Dm644 "${srcdir}/linuxpba.hook" "${pkgdir}/usr/lib/initcpio/hooks/linuxpba"
+ install -Dm644 "${srcdir}/linuxpba.install" "${pkgdir}/usr/lib/initcpio/install/linuxpba"
+ install -Dm644 "${srcdir}/linuxpba.conf" "${pkgdir}/etc/linuxpba/linuxpba.conf"
+ install -Dm644 "${srcdir}/extlinux.conf" "${pkgdir}/etc/linuxpba/extlinux.conf"
}