summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJohn Lane2018-06-29 19:28:05 +0100
committerJohn Lane2018-06-29 19:28:05 +0100
commit29cfdc4a96217091972e84bd3057ba7974defdf2 (patch)
treeeb4769416ca62f4d9055dfeb26ce110555fb8157 /PKGBUILD
parent569d887c4bcec4047d6d862258eda7dbf37d8ce7 (diff)
downloadaur-29cfdc4a96217091972e84bd3057ba7974defdf2.tar.gz
Update PKGBUILD
Set arch to x86_64 because the package contains a binary executable. Split tasks into prepare, build and package functions.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 8 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 61736689092e..8ec09dce5454 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@ pkgname=seeker
pkgver=2.0
pkgrel=2
pkgdesc='Utility to find out the storage medium access time (latency)'
-arch=(any)
+arch=(x86_64)
url="http://linuxinsight.com/how_fast_is_your_disk.html"
license=('GPL2')
depends=('gcc')
@@ -12,8 +12,14 @@ source=("http://linuxinsight.com/sites/default/files/$pkgname.c"
sha256sums=('6b7aaf278db36a7eb27e54e3abed23dab3c4594acf87d592e626df8432ec1b54'
'2ab24d77ead2bfc50f477842e9f012671ad5bf8e97d4171921d67353120cd0ba')
-package() {
+prepare() {
patch --follow-symlinks -Np2 < 0001-seeker-support-disks-2TiB.patch
+}
+
+build() {
gcc -O2 $pkgname.c -o $pkgname
+}
+
+package() {
install -Dm755 $pkgname "$pkgdir/usr/bin/$pkgname"
}