summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJohn Lane2018-06-29 19:23:50 +0100
committerJohn Lane2018-06-29 19:24:11 +0100
commit569d887c4bcec4047d6d862258eda7dbf37d8ce7 (patch)
tree6b536176c82e88a4f6b5fe3b89ca08d85b08034c /PKGBUILD
parenta3f29e453bcb7c1089f0a3fd9f6f018c2fa83342 (diff)
downloadaur-569d887c4bcec4047d6d862258eda7dbf37d8ce7.tar.gz
Patch to support devices larger than 2TiB
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 6 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d9c0b82188fd..61736689092e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,19 @@
# Maintainer: goetzc
pkgname=seeker
pkgver=2.0
-pkgrel=1
+pkgrel=2
pkgdesc='Utility to find out the storage medium access time (latency)'
arch=(any)
url="http://linuxinsight.com/how_fast_is_your_disk.html"
license=('GPL2')
depends=('gcc')
-source=("http://linuxinsight.com/sites/default/files/$pkgname.c")
-sha256sums=('6b7aaf278db36a7eb27e54e3abed23dab3c4594acf87d592e626df8432ec1b54')
+source=("http://linuxinsight.com/sites/default/files/$pkgname.c"
+ '0001-seeker-support-disks-2TiB.patch')
+sha256sums=('6b7aaf278db36a7eb27e54e3abed23dab3c4594acf87d592e626df8432ec1b54'
+ '2ab24d77ead2bfc50f477842e9f012671ad5bf8e97d4171921d67353120cd0ba')
package() {
+ patch --follow-symlinks -Np2 < 0001-seeker-support-disks-2TiB.patch
gcc -O2 $pkgname.c -o $pkgname
install -Dm755 $pkgname "$pkgdir/usr/bin/$pkgname"
}