summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorbartus2020-07-23 11:07:33 +0200
committerbartus2020-07-23 11:07:33 +0200
commit7d3102f7f2ca50f405557f54ad68ef37eddc6aad (patch)
treeecfa9d385af1856528ddb734320dbb988b5ca6cc /PKGBUILD
parent417262785339abd501d8e5ffa3a6c69f300409a7 (diff)
downloadaur-seexpr.tar.gz
Build v3.0.1 with sip:4.19.22.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 4 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e9f0085443dd..201cff908d2a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,6 @@
# Maintainer : bartus <arch-user-repoᘓbartus.33mail.com>
+_sip_ver="4.19.22"
_fragment="#tag=v3.0.1"
pkgname=('seexpr' 'seexpr-doc')
pkgver=${_fragment###tag=v}
@@ -11,7 +12,7 @@ license=('custom:Apache')
depends=('python' 'llvm-libs' 'qt5-base')
optdepends=('python-pyqt5: Editor support')
optdepends+=('boost-libs: Python bindings')
-makedepends=('boost' 'llvm' 'python-pyqt5' 'doxygen' 'libpng' 'cmake' 'git' 'sip' 'python-sip' 'gtest')
+makedepends=('boost' 'llvm' 'python-pyqt5' 'doxygen' 'libpng' 'cmake' 'git' "sip=$_sip_ver" "python-sip=$_sip_ver" 'python-pyqt5' 'gtest')
provides=("${pkgname}")
conflicts=("${pkgname}")
source=("git+https://github.com/wdas/SeExpr.git${_fragment}"
@@ -27,7 +28,8 @@ build() {
cmake \
-DCMAKE_INSTALL_PREFIX='/usr' \
-DCMAKE_INSTALL_LIBDIR='/usr/lib' \
- -DUSE_PYTHON=OFF \
+ -DUSE_PYTHON=ON \
+ -DPYQT_SIP_DIR='/usr/lib/python3.8/site-packages/PyQt5/bindings' \
-DENABLE_SLOW_TESTS=ON \
-DGTEST_DIR=/usr \
-S SeExpr \