summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel M. Capella2022-01-01 23:15:47 -0500
committerDaniel M. Capella2022-01-01 23:15:47 -0500
commitd19808276f4dde9e8ec3b300837b5103234dc007 (patch)
treed13f2647ac801e4b6d90aa2f64734f9001c5b967 /PKGBUILD
parentd267741400fe32b16399d85d9d7911cac417151e (diff)
downloadaur-d19808276f4dde9e8ec3b300837b5103234dc007.tar.gz
Use latest Rust packaging guidelines
https://wiki.archlinux.org/index.php?title=Rust_package_guidelines&diff=685804&oldid=684293 https://wiki.archlinux.org/index.php?title=Rust_package_guidelines&diff=690909&oldid=690907 https://wiki.archlinux.org/index.php?title=Rust_package_guidelines&diff=690939&oldid=690938
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 32bd45394a60..9465c1d564c6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_name=selene
pkgname=selene-linter
pkgver=0.15.0
-pkgrel=1
+pkgrel=2
pkgdesc='Blazing-fast modern Lua linter written in Rust'
arch=('x86_64')
url=https://github.com/Kampfkarren/selene
@@ -15,7 +15,7 @@ b2sums=('b18764d28691a1977041cdd35c5ba34efb52f5c0582e904309edc3820dc5626416f1d22
prepare() {
cd $_name-$pkgver
- cargo fetch --locked
+ cargo fetch --locked --target "$CARCH-unknown-linux-gnu"
}
build() {
@@ -25,7 +25,7 @@ build() {
check() {
cd $_name-$pkgver
- cargo test --release --locked --offline
+ cargo test --locked --offline
}
package() {