summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMaxim Andersson2016-06-08 22:26:35 +0200
committerMaxim Andersson2016-06-08 22:26:35 +0200
commit194bbd6d3fcdb5d71cccbf45dd808e31c1c40728 (patch)
tree3a9e62fe63c46f78ee75493ac1190b5037d84bd3 /PKGBUILD
parent7ebab1fc956fd221293e3a94fe5ef56fd812e3cb (diff)
downloadaur-194bbd6d3fcdb5d71cccbf45dd808e31c1c40728.tar.gz
Fix bug with f3 on php 7.0.7
https://github.com/SSilence/selfoss/issues/767
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 9 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 71adc3bbfa55..f5079c2bdbc4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=selfoss
pkgver=2.15
-pkgrel=1
+pkgrel=2
pkgdesc="The new multipurpose rss reader, live stream, mashup, aggregation web application"
arch=('any')
url="http://selfoss.aditu.de/"
@@ -24,6 +24,14 @@ install=${pkgname}.install
source=("https://github.com/SSilence/${pkgname}/releases/download/${pkgver}/${pkgname}-${pkgver}.zip")
sha256sums=('6a42ad93054fc8b356ac23f5ffca7347032315fa2b7b289c98d9d6b55121576b')
+prepare() {
+ cd "${srcdir}/libs/f3"
+
+ # Fix bug with f3 on php 7.0.7
+ sed -i "1185s/(\$this/(\$fw/" base.php
+ sed -i "1186s/this/fw/" base.php
+}
+
package() {
rm -rf "${srcdir}"/{README.md,${pkgname}-${pkgver}.zip}