summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJames An2016-07-10 05:33:31 -0400
committerJames An2016-07-10 05:33:31 -0400
commit884e47673dede03d3725e8a2504edc267dc3a0e8 (patch)
tree0990769990975e5cc726d6419210c82bb0b44e0a /PKGBUILD
parent3869f5615712fd914295a14cd42e94d4b951e6a4 (diff)
downloadaur-884e47673dede03d3725e8a2504edc267dc3a0e8.tar.gz
Simplified dependency list, refactored URL to source repo according to VCS guidelines, and added checksums for the two file sources.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 6 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7419e17a7169..25f9747e6eb7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=selfspy-git
_pkgname=${pkgname%-git}
pkgver=0.1.4.r194.gb0be0ab
-pkgrel=3
+pkgrel=4
epoch=1
pkgdesc="X11 personal keylogger daemon with statistical analysis."
url="https://github.com/gurgeh/selfspy"
@@ -14,21 +14,19 @@ license=('GPL')
arch=('i686' 'x86_64')
provides=("$_pkgname=$pkgver")
conflicts=("$_pkgname")
-depends=('python2'
- 'python2-daemon'
- 'python2-lockfile'
+depends=('python2-daemon'
'python2-keyring'
'python2-xlib'
'python2-sqlalchemy'
'tk'
- 'pycrypto')
+ 'python2-crypto')
makedepends=('git')
-source=("git://github.com/gurgeh/$_pkgname.git"
+source=("$_pkgname"::"git+https://github.com/gurgeh/$_pkgname.git"
"$_pkgname.conf"
"$_pkgname@.service")
md5sums=('SKIP'
- 'SKIP'
- 'SKIP')
+ 'c19d0212e7c6c1fe90c6975da9937db2'
+ '2874c55b09f87c946824dfdf4f60e1ed')
pkgver() {
cd $_pkgname