summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJames An2018-03-17 01:04:06 -0400
committerJames An2018-03-17 01:04:06 -0400
commit32feefd8a9c2b52f38bf2aaa3a3502e6cc523443 (patch)
tree781b974d80561f23508cb41bf50ab035410dbfbc /PKGBUILD
downloadaur-selfspy-vis-git.tar.gz
Initial commit with working PKGBUILD.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e53ab65ac015
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: James An <james@jamesan.ca>
+
+pkgname=selfspy-vis-git
+_pkgname=${pkgname%-git}
+pkgver=0.3.r11.ge31c023
+pkgrel=1
+pkgdesc='Visualization of Selfspy Database. Using @gurgeh /selfspy.'
+arch=('any')
+url="https://perso.crans.org/besson/publis/$_pkgname"
+license=('GPL3')
+depends=('python2-matplotlib ' 'python2-pandas' 'python2-seaborn' 'selfspy')
+makedepends=('git')
+provides=("$_pkgname=$pkgver")
+conflicts=("$_pkgname")
+source=("$_pkgname"::"git+https://github.com/Naereen/$_pkgname.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ (
+ set -o pipefail
+ git describe --long --tag | sed -r 's/([^-]*-g)/r\1/;s/-/./g;s/^v//' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+package() {
+ cd "$_pkgname"
+
+ destdir="$(python2 -c "import site; print(site.getsitepackages()[0])")/$_pkgname"
+ install -dm755 "$pkgdir/$destdir"
+ for file in *; do
+ install -D -m644 "$file" "$pkgdir/$destdir/$file"
+ done
+}