summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNicolas Iooss2019-12-08 21:11:59 +0100
committerNicolas Iooss2019-12-08 21:11:59 +0100
commit27fcf258bd0377f47574090dbfc33dade68d85eb (patch)
tree210d83e1fd29bdcc04486c5a70ddd254a660e712 /PKGBUILD
parent0763ffbe7f64cc5b3cce7dfdd3468b7eb6f8c97e (diff)
downloadaur-27fcf258bd0377f47574090dbfc33dade68d85eb.tar.gz
selinux-python 3.0-1 update
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD38
1 files changed, 8 insertions, 30 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1768d98b0e40..747a3e9173a3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,50 +3,28 @@
# This PKGBUILD is maintained on https://github.com/archlinuxhardened/selinux.
# If you want to help keep it up to date, please open a Pull Request there.
-pkgbase=selinux-python
-pkgname=(selinux-python selinux-python2)
-pkgver=2.9
-pkgrel=2
+pkgname=selinux-python
+pkgver=3.0
+pkgrel=1
pkgdesc="SELinux python tools and libraries"
groups=('selinux')
arch=('i686' 'x86_64')
url='https://github.com/SELinuxProject/selinux/wiki'
license=('GPL2')
-makedepends=('python2' 'python' 'python-ipy' 'libsemanage>=2.8' 'setools>=4.0.0')
+depends=('python' 'python-audit' 'python-ipy' 'libsemanage>=2.8' 'setools>=4.0.0')
conflicts=('sepolgen<2.7' 'policycoreutils<2.7')
provides=("sepolgen=${pkgver}-${pkgrel}")
-source=("https://github.com/SELinuxProject/selinux/releases/download/20190315/${pkgname}-${pkgver}.tar.gz")
-sha256sums=('3650b5393b0d1790cac66db00e34f059aa91c23cfe3c2559676594e295d75fde')
+source=("https://github.com/SELinuxProject/selinux/releases/download/20191204/${pkgname}-${pkgver}.tar.gz")
+sha256sums=('43c08fa881ccc64251d396b1ac6c56b354bf98421b4ec937d54a8db190135494')
build() {
cd "${pkgbase}-${pkgver}"
- make PYTHON=/usr/bin/python2
make PYTHON=/usr/bin/python3
}
-package_selinux-python() {
- depends=('python' 'python-audit' 'python-ipy' 'libsemanage>=2.8' 'setools>=4.0.0')
-
+package() {
cd "${pkgbase}-${pkgver}"
make PYTHON=/usr/bin/python3 DESTDIR="${pkgdir}" SBINDIR=/usr/bin install
/usr/bin/python3 -m compileall "${pkgdir}/$(/usr/bin/python3 -c 'import site; print(site.getsitepackages()[0])')"
-}
-
-package_selinux-python2() {
- depends=('python2' 'libsemanage>=2.8' 'setools>=4.0.0')
-
- cd "${pkgbase}-${pkgver}"
-
- # Guide the files which would conflict with selinux-python package into a
- # special directory, which would then be removed
- make PYTHON=/usr/bin/python2 DESTDIR="${pkgdir}" \
- BASHCOMPLETIONDIR=/removed \
- BINDIR=/removed \
- LIBDIR=/removed \
- MANDIR=/removed \
- SBINDIR=/removed \
- SHAREDIR=/removed \
- install
- rm -r "${pkgdir}/removed"
- /usr/bin/python2 -m compileall "${pkgdir}/$(/usr/bin/python2 -c 'import site; print(site.getsitepackages()[0])')"
+ /usr/bin/python3 -O -m compileall "${pkgdir}/$(/usr/bin/python3 -c 'import site; print(site.getsitepackages()[0])')"
}