summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNicolas Iooss2018-11-11 22:07:04 +0100
committerNicolas Iooss2018-11-19 21:30:10 +0100
commitc7941c1604e6f9c917c449f63df5dd535c5dbddf (patch)
tree97e86177d79ce71820ca25b6a9899eb2217ebe4d /PKGBUILD
parent26591cccaef49bbb5cac471ac73a221b07603f02 (diff)
downloadaur-c7941c1604e6f9c917c449f63df5dd535c5dbddf.tar.gz
selinux-python 2.8-3 update: support SETools 4.2.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 10 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6c5db5661963..0e84a70ad2fb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
pkgbase=selinux-python
pkgname=(selinux-python selinux-python2)
pkgver=2.8
-pkgrel=2
+pkgrel=3
pkgdesc="SELinux python tools and libraries"
groups=('selinux')
arch=('i686' 'x86_64')
@@ -15,8 +15,15 @@ license=('GPL2')
makedepends=('python2' 'python' 'python-ipy' 'libsemanage>=2.8' 'setools>=4.0.0')
conflicts=('sepolgen<2.7' 'policycoreutils<2.7')
provides=("sepolgen=${pkgver}-${pkgrel}")
-source=("https://raw.githubusercontent.com/wiki/SELinuxProject/selinux/files/releases/20180524/${pkgname}-${pkgver}.tar.gz")
-sha256sums=('e69f5e24820cb247a3d881a9c90efba1e64d76af863c82fb81bc3b87ed71e238')
+source=("https://raw.githubusercontent.com/wiki/SELinuxProject/selinux/files/releases/20180524/${pkgname}-${pkgver}.tar.gz"
+ '0001-python-sepolicy-Update-to-work-with-setools-4.2.0.patch')
+sha256sums=('e69f5e24820cb247a3d881a9c90efba1e64d76af863c82fb81bc3b87ed71e238'
+ 'f95c0bb79f86c79abdbc1f3ec3bcb13294f2e10181df15d8ab5a8b54569918f1')
+
+prepare() {
+ cd "${pkgbase}-${pkgver}"
+ patch -p2 -i "$srcdir/0001-python-sepolicy-Update-to-work-with-setools-4.2.0.patch"
+}
build() {
cd "${pkgbase}-${pkgver}"