summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPellegrino Prevete2022-06-16 01:17:47 +0000
committerPellegrino Prevete2022-06-16 01:17:47 +0000
commitd834e2a650f473300f2a749929c79bca4a59a57e (patch)
tree119c3d4c13f93bd9aad74813b5db66c002e714e0 /PKGBUILD
parentb4dd1670be6b0c793e5a417a932a2e12d9d76a7a (diff)
downloadaur-selinux-python2.tar.gz
upgrade to 3.4 (possible regression)
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 9 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c384d1778641..6b8ff3b5318a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,27 +3,29 @@
# This PKGBUILD is maintained on https://github.com/archlinuxhardened/selinux.
# If you want to help keep it up to date, please open a Pull Request there.
-pkgname=selinux-python2
-pkgver=3.0
+_pkgname=selinux-python
+pkgname="${_pkgname}2"
+pkgver=3.4
pkgrel=1
pkgdesc="SELinux python 2.X tools and libraries"
groups=('selinux')
arch=('i686' 'x86_64')
-url='https://github.com/SELinuxProject/selinux/wiki'
+_url="https://github.com/SELinuxProject/selinux"
+url="${_url}/wiki"
license=('GPL2')
depends=('python2' 'python2-audit' 'python2-ipy' 'libsemanage>=2.8' 'setools>=4.0.0')
conflicts=('sepolgen<2.7' 'policycoreutils<2.7')
provides=("sepolgen=${pkgver}-${pkgrel}")
-source=("https://github.com/SELinuxProject/selinux/releases/download/20191204/selinux-python-${pkgver}.tar.gz")
-sha256sums=('43c08fa881ccc64251d396b1ac6c56b354bf98421b4ec937d54a8db190135494')
+source=("${_url}/releases/download/${pkgver}/selinux-python-${pkgver}.tar.gz")
+sha256sums=("1731065a58293b8a598c0f8b182fdd1a278959b1288747fcb17af392496bac32")
build() {
- cd "selinux-python-${pkgver}"
+ cd "${_pkgname}-${pkgver}"
make PYTHON=/usr/bin/python2
}
package() {
- cd "selinux-python-${pkgver}"
+ cd "${_pkgname}-${pkgver}"
make PYTHON=/usr/bin/python2 DESTDIR="${pkgdir}" SBINDIR=/usr/bin install
/usr/bin/python2 -m compileall "${pkgdir}/$(/usr/bin/python2 -c 'import site; print(site.getsitepackages()[0])')"
/usr/bin/python2 -O -m compileall "${pkgdir}/$(/usr/bin/python2 -c 'import site; print(site.getsitepackages()[0])')"