summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNicolas Iooss2021-10-11 21:41:48 +0200
committerNicolas Iooss2021-10-12 19:54:01 +0200
commitbb337047ae2b6b23cbcbbffff99a1f046097a9c7 (patch)
treed9e8d4a63e3c77aa014aec61852ee789006ea69e /PKGBUILD
parent5667cef0500570d3abfa3e5870a6d00757960de4 (diff)
downloadaur-bb337047ae2b6b23cbcbbffff99a1f046097a9c7.tar.gz
selinux-refpolicy-arch: move configuration step into build()
https://wiki.archlinux.org/title/creating_packages describes that prepare() is used to prepare the source. Running actions similar to "./configure" (here it is "make conf") should happen in build().
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 1 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ccc415970cab..e970d25ba185 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -24,15 +24,10 @@ source=("git+https://github.com/archlinuxhardened/${_reponame}#commit=${_commit}
sha256sums=('SKIP'
'c9f7cce9a06fd0595b3dd47d4fdde9d9c7457120c42c5f08bfdc5e89eb9a61df')
-prepare() {
+build() {
cd "${srcdir}/${_reponame}"
-
make bare
make conf
-}
-
-build() {
- cd "${srcdir}/${_reponame}"
make
}