summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNicolas Iooss2014-10-24 13:35:27 +0200
committerNicolas Iooss2015-06-27 11:44:57 +0800
commit236fc869029e32ea77e128f54fc173e2e1b26386 (patch)
tree2e3a19f0f8308bc0e6bf2d137c0a07e18948cf5f /PKGBUILD
downloadaur-236fc869029e32ea77e128f54fc173e2e1b26386.tar.gz
Import selinux-refpolicy-src 20130424-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..59260a267901
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Nicky726 (Nicky726 <at> gmail <dot> com)
+# Contributor: Sergej Pupykin (pupykin <dot> s+arch <at> gmail <dot> com)
+
+pkgname=selinux-refpolicy-src
+_origname=refpolicy
+pkgver=20130424
+pkgrel=1
+pkgdesc="SELinux reference policy sources"
+arch=('any')
+url="http://oss.tresys.com/projects/refpolicy"
+license=('GPL')
+groups=('selinux' 'selinux-policies')
+depends=('linux-selinux')
+makedepends=('selinux-usr-checkpolicy>=2.1.8' 'selinux-usr-policycoreutils>=2.1.10'
+ 'selinux-usr-libsepol>=2.1.4' 'selinux-usr-libsemanage>=2.0.29'
+ 'pyxml')
+source=(http://oss.tresys.com/files/${_origname}/${_origname}-2.${pkgver}.tar.bz2)
+sha256sums=('6039ba854f244a39dc727cc7db25632f7b933bb271c803772d754d4354f5aef4')
+
+package() {
+ cd "${srcdir}/${_origname}"
+ sed -i -e "s/python/python2/" Makefile
+ make DESTDIR="${pkgdir}" install-src
+}