summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNicolas Iooss2017-08-11 13:56:40 +0200
committerNicolas Iooss2017-08-11 13:56:40 +0200
commit896c0cde1ac8b195b05613b194718b51befbcd22 (patch)
tree33bc61aa1f0da3615cf1c97c7d25bc72c0ff6bcb /PKGBUILD
downloadaur-896c0cde1ac8b195b05613b194718b51befbcd22.tar.gz
Create selinux-sandbox package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fae2d9a57157
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Nicolas Iooss (nicolas <dot> iooss <at> m4x <dot> org)
+
+pkgname=selinux-sandbox
+pkgver=2.7
+pkgrel=1
+pkgdesc="sandboxing tool for SELinux"
+arch=('i686' 'x86_64')
+url='https://github.com/SELinuxProject/selinux/wiki'
+license=('GPL2')
+groups=('selinux')
+depends=('libcap-ng' 'selinux-python')
+conflicts=('policycoreutils<2.7')
+source=("https://raw.githubusercontent.com/wiki/SELinuxProject/selinux/files/releases/20170804/${pkgname}-${pkgver}.tar.gz")
+sha256sums=('9490620380ab6d428a92869002a51ada0343ca35fa2a6905595745902a64c541')
+
+build() {
+ cd "${pkgname}-${pkgver}"
+
+ make
+}
+
+package() {
+ cd "${pkgname}-${pkgver}"
+
+ make DESTDIR="${pkgdir}" SBINDIR="${pkgdir}/usr/bin" install
+}