summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorYe Shu2019-03-09 15:59:22 +0800
committerYe Shu2019-03-09 15:59:22 +0800
commit14c03572e7a85a0606b83f647cde285312f063b7 (patch)
tree7c20804be17abe39648d6cfa860828b127af06d8 /PKGBUILD
parentf19eb4d5269fa5343ed21ed63df6ea7f8620dfdf (diff)
downloadaur-14c03572e7a85a0606b83f647cde285312f063b7.tar.gz
Add Licenses & Update version to 9.3.5
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 21 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 97e144c2ec54..d2828fa85afd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,32 @@
-# Maintainer: Aaron Fischer <mail@aaron-fischer.net>
+# Maintainer: Ye Shu <shuye02@outlook.com>
+# Contributor: Aaron Fischer <mail@aaron-fischer.net>
# Contributor: Ashwin Vishnu <ashuwish+arch at gmail dot com>
pkgname=sendanywhere
-pkgver=8.5.28
-pkgrel=3
-pkgdesc="Send Anywhere is a multi-platform file sharing service where users can directly share digital content in real time."
+pkgver=9.3.5
+pkgrel=1
arch=('x86_64')
+
+pkgdesc="Send Anywhere is a multi-platform file sharing service where users can directly share digital content in real time."
url="http://send-anywhere.com"
-license=('custom:sendanywhere_eula')
-options=('!strip' '!emptydirs')
-depends=('nss' 'libxtst' 'libxss' 'gconf' 'gtk2' 'alsa-lib')
-source=("${pkgname}-${pkgver}.deb::https://update.send-anywhere.com/linux_downloads/sendanywhere_latest_amd64.deb")
-sha512sums=('f1e7af787bf936f2ec6e385de4ba2ce160a2199ea5d66f5a9fb8cc955a37084bbb9e744ff2cbe60739e87587275b5e5a3bdd3685c6e75e848cf245f89646eb1a')
+license=('custom')
+depends=('gconf' 'libxtst' 'nss' 'libxss' 'alsa-lib' 'gtk2')
+
+source=("${pkgname}-${pkgver}.deb::https://update.send-anywhere.com/linux_downloads/sendanywhere_latest_amd64.deb" "LICENSE")
+sha512sums=('ae3799a2822284dedeff3e48bbab8cae9407abe98eb96e91e701261b266e000428be25daf322d0ebde55f0393986bc83e89efed3d36c67f3d0163641c1f9af9f'
+ 'aeb97a12f246d78cbf202354148b429a037997d68087bceed5d5ce5036443d779c2535138b54347579ddf05994a61b9333913f9261733f367d02e0e9cf7d0b5e')
+# If validity check fails, please leave a comment to remind me to update the package version
package(){
- tar xf data.tar.xz -C "$pkgdir"
+ # Extract the data package
+ tar -xf data.tar.xz --directory="$pkgdir"
+ # Add licenses
+ install -Dm644 $srcdir/LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
install -Dm644 "$pkgdir/opt/SendAnywhere/LICENSE.electron.txt" "$pkgdir/usr/share/licenses/$pkgname/LICENSE.electron.txt"
install -Dm644 "$pkgdir/opt/SendAnywhere/LICENSES.chromium.html" "$pkgdir/usr/share/licenses/$pkgname/LICENSES.chromium.html"
+
+ # Create soft link
+ mkdir -p $pkgdir/usr/bin
+ ln -sf "/opt/SendAnywhere/SendAnywhere" "$pkgdir/usr/bin/SendAnywhere"
}