summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRicardo (XenGi) Band2018-12-29 22:52:03 +0100
committerRicardo (XenGi) Band2018-12-29 22:52:03 +0100
commit3c2d69298767acd58332f867f1473d0f2e5f889f (patch)
treedcb595371b3e4c9c5df13b270eb3fde337207c5b /PKGBUILD
downloadaur-3c2d69298767acd58332f867f1473d0f2e5f889f.tar.gz
initial dump
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6ca68d6792a8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Ricardo (XenGi) Band <email@ricardo.band>
+pkgname=sensu-go-cli
+pkgver=5.1.0
+_pkgver=5.1.0-0ubuntu18.1
+pkgrel=1
+pkgdesc="Sensu Go CLI"
+arch=('x86_64')
+url='https://sensu.io'
+license=('MIT')
+source=("${pkgname}-${_pkgver}_amd64.deb::https://packagecloud.io/sensu/stable/packages/ubuntu/cosmic/${pkgname}_${_pkgver}_amd64.deb/download.deb")
+sha1sums=('efaf21b93d40a1f5cd2ae3c670f036ccc7a43978')
+
+prepare() {
+ cd "${srcdir}"
+ tar xaf data.tar.gz
+}
+
+# TODO: better build from source
+# build() {}
+
+package() {
+ install -Dm755 "${srcdir}/usr/bin/sensuctl" "${pkgdir}/usr/bin/sensuctl"
+ install -Dm644 "${srcdir}/usr/share/doc/${pkgname}-${pkgver}/LICENSE.txt" "${pkgdir}/usr/share/doc/${pkgname}-${pkgver}/LICENSE.txt"
+ install -Dm644 "${srcdir}/usr/share/doc/${pkgname}-${pkgver}/README.txt" "${pkgdir}/usr/share/doc/${pkgname}-${pkgver}/README.txt"
+}
+